net-mail/dovecot: bump to 2.3.3
authorEray Aslan <eras@gentoo.org>
Fri, 5 Oct 2018 11:03:52 +0000 (14:03 +0300)
committerEray Aslan <eras@gentoo.org>
Fri, 5 Oct 2018 11:03:52 +0000 (14:03 +0300)
Closes: https://bugs.gentoo.org/666202
Closes: https://bugs.gentoo.org/667118
Closes: https://bugs.gentoo.org/664988
Signed-off-by: Eray Aslan <eras@gentoo.org>
Package-Manager: Portage-2.3.50, Repoman-2.3.11

net-mail/dovecot/Manifest
net-mail/dovecot/dovecot-2.3.3.ebuild [new file with mode: 0644]
net-mail/dovecot/files/dovecot-glibc228.patch [new file with mode: 0644]
net-mail/dovecot/files/dovecot.init-r5 [new file with mode: 0644]

index bf8481d15dc6631856924a9ec1482128b54c60d1..1a99069f813f874dba2ab90028a8ed29aa0290d0 100644 (file)
@@ -5,4 +5,6 @@ DIST dovecot-2.2.19.tar.gz 5256627 BLAKE2B 0b7fe57ced1b1f7eb5e29e8d6723d237cc107
 DIST dovecot-2.2.34.tar.gz 6181270 BLAKE2B dfdb1e6812574e79595202e830167400569adf61155aa5ddaae443e798c4a05ccec2acd2975e00e9e7ffc63ee1dcf7e4e2a9288b1e6e1e1427d1e89790a8fa13 SHA512 9f08a7116a08a08495aa0e7b4cb6b11a924ea61006970487946e338bc79bba7fd7619c345cbf278a74de285d548af04fc66eaaee508185b8b9d7335cf5612055
 DIST dovecot-2.2.36.tar.gz 6239707 BLAKE2B 702bb24265b5fefec9c484b3cca890fb1536ff94d1f2d6c99ee8c294ee4e38091eef5a727f0d4bd03700263286361f55747a22fa74def350710f9e49a4b10580 SHA512 327c50971e276f6013ca7f7bb59498ee88d76c9f8419bd18ee531cf10142214350fb81c6d64eaef73ee01765dd0fcf4142ab146ed67d9d7d86d5a58d41cf8db5
 DIST dovecot-2.3-pigeonhole-0.5.2.tar.gz 1814618 BLAKE2B b1187021673429bee1b45a1f657bea995e9881257919ff55bac63106d65963294ee2b3829167c6d50e351c4bc3c7e88a5ccfb757308d2500c5d4146246145074 SHA512 6bc24d9241f94db795a012346d9bc94b5cc7d7ce0175c03213c2b5d179d80dec95e9bdbd50bed628c8f9f7c51639e692ba5e429212a3b4a654c1e4764ac4f11c
+DIST dovecot-2.3-pigeonhole-0.5.3.tar.gz 1827329 BLAKE2B 0d484906022217b1082233e6a3a20c17bafc68b90ce1c5c956c714d111ffb9ab49a3794e199695bb61a1f3ad6bd46e56e63ee3c140cb01eaa7589ef7bd754b19 SHA512 8403b1976a915836ba875b96825446d46e0d8c7ff245ed1f2b014347fdc78a81f9ed6dbd05bd3b4f1f7072edc5e9a302201cdb375de44436adcbb83919f203f5
 DIST dovecot-2.3.2.1.tar.gz 6797491 BLAKE2B 92b88fd0f0cb8ed6c418bf27c2e1fc4efe13f1ccfb4948ce5eed1a4e76a4e96f0d6770d9841026ec5a515310ebaa4b335063e3516de454db8ba06cc4ee5a00ec SHA512 c085a0d04925485423086736a3c7d919ad0ca9efeff005890382da5333edb68c7d23ccb89fbe2ac44f8f016fc993bf2c669e450794c3ab13463676cbb47c7bf7
+DIST dovecot-2.3.3.tar.gz 6851107 BLAKE2B 87d6e11c8ff59cfe0b49d3561c307535efb09296af617530a4d5a89b4fc12055d006d1b283a4de076f27d59deb64324b96f28620958ad85c38197710c5decdf7 SHA512 8666c4f92f7df883067540f85be9d03dbe6815b58a7f5de55b4292e986e9a2a1ef52c7e0c72dde2bc781fe40d57488b78a99b6b813745b8e4683f1a2fdc1f2ff
diff --git a/net-mail/dovecot/dovecot-2.3.3.ebuild b/net-mail/dovecot/dovecot-2.3.3.ebuild
new file mode 100644 (file)
index 0000000..9d28a29
--- /dev/null
@@ -0,0 +1,291 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+# do not add a ssl USE flag.  ssl is mandatory
+SSL_DEPS_SKIP=1
+inherit autotools ssl-cert systemd user versionator
+
+MY_P="${P/_/.}"
+#MY_S="${PN}-ce-${PV}"
+major_minor="$(get_version_component_range 1-2)"
+sieve_version="0.5.3"
+if [[ ${PV} == *_rc* ]] ; then
+       rc_dir="rc/"
+else
+       rc_dir=""
+fi
+SRC_URI="https://dovecot.org/releases/${major_minor}/${rc_dir}${MY_P}.tar.gz
+       sieve? (
+       https://pigeonhole.dovecot.org/releases/${major_minor}/${rc_dir}${PN}-${major_minor}-pigeonhole-${sieve_version}.tar.gz
+       )
+       managesieve? (
+       https://pigeonhole.dovecot.org/releases/${major_minor}/${rc_dir}${PN}-${major_minor}-pigeonhole-${sieve_version}.tar.gz
+       ) "
+DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
+HOMEPAGE="https://www.dovecot.org/"
+
+SLOT="0"
+LICENSE="LGPL-2.1 MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IUSE_DOVECOT_AUTH="kerberos ldap lua mysql pam postgres sqlite vpopmail"
+IUSE_DOVECOT_COMPRESS="bzip2 lzma lz4 zlib"
+IUSE_DOVECOT_OTHER="argon2 caps doc ipv6 libressl lucene managesieve selinux sieve solr static-libs suid tcpd textcat"
+
+IUSE="${IUSE_DOVECOT_AUTH} ${IUSE_DOVECOT_STORAGE} ${IUSE_DOVECOT_COMPRESS} ${IUSE_DOVECOT_OTHER}"
+
+DEPEND="argon2? ( dev-libs/libsodium )
+       bzip2? ( app-arch/bzip2 )
+       caps? ( sys-libs/libcap )
+       kerberos? ( virtual/krb5 )
+       ldap? ( net-nds/openldap )
+       lua? ( dev-lang/lua:* )
+       lucene? ( >=dev-cpp/clucene-2.3 )
+       lzma? ( app-arch/xz-utils )
+       lz4? ( app-arch/lz4 )
+       mysql? ( virtual/mysql )
+       pam? ( virtual/pam )
+       postgres? ( dev-db/postgresql:* !dev-db/postgresql[ldap,threads] )
+       selinux? ( sec-policy/selinux-dovecot )
+       solr? ( net-misc/curl dev-libs/expat )
+       sqlite? ( dev-db/sqlite:* )
+       !libressl? ( dev-libs/openssl:0 )
+       libressl? ( dev-libs/libressl )
+       tcpd? ( sys-apps/tcp-wrappers )
+       textcat? ( app-text/libexttextcat )
+       vpopmail? ( net-mail/vpopmail )
+       zlib? ( sys-libs/zlib )
+       virtual/libiconv
+       dev-libs/icu:="
+
+RDEPEND="${DEPEND}
+       net-mail/mailbase"
+
+PATCHES=( "${FILESDIR}/${PN}-glibc228.patch" )
+
+pkg_setup() {
+       if use managesieve && ! use sieve; then
+               ewarn "managesieve USE flag selected but sieve USE flag unselected"
+               ewarn "sieve USE flag will be turned on"
+       fi
+       # default internal user
+       enewgroup dovecot 97
+       enewuser dovecot 97 -1 /dev/null dovecot
+       # default login user
+       enewuser dovenull -1 -1 /dev/null
+       # add "mail" group for suid'ing. Better security isolation.
+       if use suid; then
+               enewgroup mail
+       fi
+}
+
+src_prepare() {
+       default
+       # bug 657108
+       # elibtoolize
+       eautoreconf
+}
+
+src_configure() {
+       local conf=""
+
+       if use postgres || use mysql || use sqlite; then
+               conf="${conf} --with-sql"
+       fi
+
+       # turn valgrind tests off. Bug #340791
+       VALGRIND=no econf \
+               --with-rundir="${EPREFIX}/run/dovecot" \
+               --with-statedir="${EPREFIX}/var/lib/dovecot" \
+               --with-moduledir="${EPREFIX}/usr/$(get_libdir)/dovecot" \
+               --without-stemmer \
+               --disable-rpath \
+               --without-libbsd \
+               --with-icu \
+               --with-ssl \
+               --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+               $( use_with argon2 sodium ) \
+               $( use_with bzip2 bzlib ) \
+               $( use_with caps libcap ) \
+               $( use_with kerberos gssapi ) \
+               $( use_with lua ) \
+               $( use_with ldap ) \
+               $( use_with lucene ) \
+               $( use_with lz4 ) \
+               $( use_with lzma ) \
+               $( use_with mysql ) \
+               $( use_with pam ) \
+               $( use_with postgres pgsql ) \
+               $( use_with sqlite ) \
+               $( use_with solr ) \
+               $( use_with tcpd libwrap ) \
+               $( use_with textcat ) \
+               $( use_with vpopmail ) \
+               $( use_with zlib ) \
+               $( use_enable static-libs static ) \
+               ${conf}
+
+       if use sieve || use managesieve ; then
+               # The sieve plugin needs this file to be build to determine the plugin
+               # directory and the list of libraries to link to.
+               emake dovecot-config
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               econf \
+                       $( use_enable static-libs static ) \
+                       --localstatedir="${EPREFIX%/}/var" \
+                       --enable-shared \
+                       --with-dovecot="${S}" \
+                       $( use_with managesieve )
+       fi
+}
+
+src_compile() {
+       default
+       if use sieve || use managesieve ; then
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+       fi
+}
+
+src_test() {
+       default
+       if use sieve || use managesieve ; then
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               default
+       fi
+}
+
+src_install () {
+       default
+
+       # insecure:
+       # use suid && fperms u+s /usr/libexec/dovecot/deliver
+       # better:
+       if use suid;then
+               einfo "Changing perms to allow deliver to be suided"
+               fowners root:mail "${EPREFIX}/usr/libexec/dovecot/dovecot-lda"
+               fperms 4750 "${EPREFIX}/usr/libexec/dovecot/dovecot-lda"
+       fi
+
+       newinitd "${FILESDIR}"/dovecot.init-r5 dovecot
+
+       rm -rf "${ED}"/usr/share/doc/dovecot
+
+       dodoc AUTHORS NEWS README TODO
+       dodoc doc/*.{txt,cnf,xml,sh}
+       docinto example-config
+       dodoc doc/example-config/*.{conf,ext}
+       docinto example-config/conf.d
+       dodoc doc/example-config/conf.d/*.{conf,ext}
+       docinto wiki
+       dodoc doc/wiki/*
+       doman doc/man/*.{1,7}
+
+       # Create the dovecot.conf file from the dovecot-example.conf file that
+       # the dovecot folks nicely left for us....
+       local conf="${ED}/etc/dovecot/dovecot.conf"
+       local confd="${ED}/etc/dovecot/conf.d"
+
+       insinto /etc/dovecot
+       doins doc/example-config/*.{conf,ext}
+       insinto /etc/dovecot/conf.d
+       doins doc/example-config/conf.d/*.{conf,ext}
+       fperms 0600 "${EPREFIX}"/etc/dovecot/dovecot-{ldap,sql}.conf.ext
+       rm -f "${confd}/../README"
+
+       # .maildir is the Gentoo default
+       local mail_location="maildir:~/.maildir"
+       sed -i -e \
+               "s|#mail_location =|mail_location = ${mail_location}|" \
+               "${confd}/10-mail.conf" \
+               || die "failed to update mail location settings in 10-mail.conf"
+
+       # We're using pam files (imap and pop3) provided by mailbase
+       if use pam; then
+               sed -i -e '/driver = pam/,/^[ \t]*}/ s|#args = dovecot|args = "\*"|' \
+                       "${confd}/auth-system.conf.ext" \
+                       || die "failed to update PAM settings in auth-system.conf.ext"
+               # mailbase does not provide a sieve pam file
+               use managesieve && dosym imap /etc/pam.d/sieve
+               sed -i -e \
+                       's/#!include auth-system.conf.ext/!include auth-system.conf.ext/' \
+                       "${confd}/10-auth.conf" \
+                       || die "failed to update PAM settings in 10-auth.conf"
+       fi
+
+       # Disable ipv6 if necessary
+       if ! use ipv6; then
+               sed -i -e 's/^#listen = \*, ::/listen = \*/g' "${conf}" \
+                       || die "failed to update listen settings in dovecot.conf"
+       fi
+
+       # Update ssl cert locations
+       sed -i -e 's:^#ssl = yes:ssl = yes:' "${confd}/10-ssl.conf" \
+               || die "ssl conf failed"
+       sed -i -e 's:^ssl_cert =.*:ssl_cert = </etc/ssl/dovecot/server.pem:' \
+               -e 's:^ssl_key =.*:ssl_key = </etc/ssl/dovecot/server.key:' \
+               "${confd}/10-ssl.conf" || die "failed to update SSL settings in 10-ssl.conf"
+
+       # Install SQL configuration
+       if use mysql || use postgres; then
+               sed -i -e \
+                       's/#!include auth-sql.conf.ext/!include auth-sql.conf.ext/' \
+                       "${confd}/10-auth.conf" || die "failed to update SQL settings in \
+                       10-auth.conf"
+       fi
+
+       # Install LDAP configuration
+       if use ldap; then
+               sed -i -e \
+                       's/#!include auth-ldap.conf.ext/!include auth-ldap.conf.ext/' \
+                       "${confd}/10-auth.conf" \
+                       || die "failed to update ldap settings in 10-auth.conf"
+       fi
+
+       if use vpopmail; then
+               sed -i -e \
+                       's/#!include auth-vpopmail.conf.ext/!include auth-vpopmail.conf.ext/' \
+                       "${confd}/10-auth.conf" \
+                       || die "failed to update vpopmail settings in 10-auth.conf"
+       fi
+
+       if use sieve || use managesieve ; then
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               emake DESTDIR="${ED}" install
+               sed -i -e \
+                       's/^[[:space:]]*#mail_plugins = $mail_plugins/mail_plugins = sieve/' "${confd}/15-lda.conf" \
+                       || die "failed to update sieve settings in 15-lda.conf"
+               rm -rf "${ED}"/usr/share/doc/dovecot
+               docinto example-config/conf.d
+               dodoc doc/example-config/conf.d/*.conf
+               insinto /etc/dovecot/conf.d
+               doins doc/example-config/conf.d/90-sieve{,-extprograms}.conf
+               use managesieve && doins doc/example-config/conf.d/20-managesieve.conf
+               docinto sieve/rfc
+               dodoc doc/rfc/*.txt
+               docinto sieve/devel
+               dodoc doc/devel/DESIGN
+               docinto plugins
+               dodoc doc/plugins/*.txt
+               docinto extensions
+               dodoc doc/extensions/*.txt
+               docinto locations
+               dodoc doc/locations/*.txt
+               doman doc/man/*.{1,7}
+       fi
+
+       use static-libs || find "${ED}"/usr/lib* -name '*.la' -delete
+}
+
+pkg_postinst() {
+       # Let's not make a new certificate if we already have one
+       if ! [[ -e "${ROOT}"/etc/ssl/dovecot/server.pem && \
+               -e "${ROOT}"/etc/ssl/dovecot/server.key ]];     then
+               einfo "Creating SSL     certificate"
+               SSL_ORGANIZATION="${SSL_ORGANIZATION:-Dovecot IMAP Server}"
+               install_cert /etc/ssl/dovecot/server
+       fi
+
+       elog "Please read http://wiki2.dovecot.org/Upgrading/ for upgrade notes."
+}
diff --git a/net-mail/dovecot/files/dovecot-glibc228.patch b/net-mail/dovecot/files/dovecot-glibc228.patch
new file mode 100644 (file)
index 0000000..9549c12
--- /dev/null
@@ -0,0 +1,44 @@
+From 63a74b9e8e0604486a15a879e7f1a27257322400 Mon Sep 17 00:00:00 2001
+From: Aki Tuomi <aki.tuomi@dovecot.fi>
+Date: Wed, 8 Aug 2018 12:33:20 +0300
+Subject: [PATCH] auth: mycrypt - include crypt.h
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fixes crypt usage on glibc-2.28
+
+Reported by Reuben Farrelly
+Patch provided by Thore Bödecker
+---
+ configure.ac       | 2 +-
+ src/auth/mycrypt.c | 3 +++
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index dd545ebfdc..c5d8fae666 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -315,7 +315,7 @@ AC_CHECK_HEADERS(strings.h stdint.h unistd.h dirent.h malloc.h \
+   quota.h sys/fs/quota_common.h \
+   mntent.h sys/mnttab.h sys/event.h sys/time.h sys/mkdev.h linux/dqblk_xfs.h \
+   xfs/xqm.h execinfo.h ucontext.h malloc_np.h sys/utsname.h sys/vmount.h \
+-  sys/utsname.h glob.h linux/falloc.h ucred.h sys/ucred.h)
++  sys/utsname.h glob.h linux/falloc.h ucred.h sys/ucred.h crypt.h)
+ CC_CLANG
+ AC_CC_PIE
+diff --git a/src/auth/mycrypt.c b/src/auth/mycrypt.c
+index c49fcf842e..0bd00bc238 100644
+--- a/src/auth/mycrypt.c
++++ b/src/auth/mycrypt.c
+@@ -14,6 +14,9 @@
+ #  define _XPG6 /* Some Solaris versions require this, some break with this */
+ #endif
+ #include <unistd.h>
++#ifdef HAVE_CRYPT_H
++# include <crypt.h>
++#endif
+ #include "mycrypt.h"
diff --git a/net-mail/dovecot/files/dovecot.init-r5 b/net-mail/dovecot/files/dovecot.init-r5
new file mode 100644 (file)
index 0000000..8a98603
--- /dev/null
@@ -0,0 +1,57 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License, v2 or later
+
+extra_started_commands="reload"
+
+depend() {
+       need localmount
+       before postfix
+       after bootmisc ldap mysql ntp-client ntpd postgresql saslauthd slapd 
+       use logger net
+}
+
+checkconfig() {
+       DOVECOT_INSTANCE=${SVCNAME##*.}
+       if [ -n "${DOVECOT_INSTANCE}" -a "${SVCNAME}" != "dovecot" ]; then
+               DOVECOT_CONF=/etc/dovecot/dovecot.${DOVECOT_INSTANCE}.conf
+       else
+               DOVECOT_CONF=/etc/dovecot/dovecot.conf
+       fi
+       if [ ! -e ${DOVECOT_CONF} ]; then
+               eerror "You will need an ${DOVECOT_CONF} first"
+               return 1
+       fi
+       if [ -x /usr/sbin/dovecot ]; then
+               DOVECOT_BASEDIR=$(/usr/sbin/dovecot -c ${DOVECOT_CONF} config -h base_dir)
+       else
+               eerror "dovecot not executable"
+               return 1
+       fi
+       DOVECOT_BASEDIR=${DOVECOT_BASEDIR:-/run/dovecot}
+       DOVECOT_PIDFILE=${DOVECOT_BASEDIR}/master.pid
+}
+
+start() {
+       checkconfig || return 1
+       ebegin "Starting ${SVCNAME}"
+       start-stop-daemon --start --exec /usr/sbin/dovecot \
+               --pidfile "${DOVECOT_PIDFILE}" -- -c "${DOVECOT_CONF}"
+       eend $?
+}
+
+stop() {
+       checkconfig || return 1
+       ebegin "Stopping ${SVCNAME}"
+       start-stop-daemon --stop --exec /usr/sbin/dovecot \
+               --pidfile "${DOVECOT_PIDFILE}"
+       eend $?
+}
+
+reload() {
+       checkconfig || return 1
+       ebegin "Reloading ${SVCNAME} configs and restarting auth/login processes"
+       start-stop-daemon --signal HUP --exec /usr/sbin/dovecot \
+               --pidfile "${DOVECOT_PIDFILE}"
+       eend $?
+}