dev-python/python-zaqarclient: 1.3.1 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 12 May 2020 23:59:51 +0000 (18:59 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 13 May 2020 00:00:35 +0000 (19:00 -0500)
Closes: https://bugs.gentoo.org/722510

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/python-zaqarclient/Manifest
dev-python/python-zaqarclient/python-zaqarclient-1.13.1.ebuild [new file with mode: 0644]

index 4b7facc12a18481260d154af46de155d0de2f36e..23880a39dd7d07ed90ed2fffed41b83bd384a04a 100644 (file)
@@ -1 +1,2 @@
 DIST python-zaqarclient-1.11.0.tar.gz 85724 BLAKE2B 84e34998a76bd475b3aad2882f076f8ca89dcfc1a24155d0e88269fda3d82d4b1348461d1f59a5f21726dbc56b37219d9e75957737452e759672505a1f16a4c9 SHA512 4b57cd336a6517760d32a5e01a7c87a9ee0526323a222faa6fcd6e33a506b0746d6418e9eee3fa00e7ba4a01912ee108fe1feb3469e0a14089cc760a0756b7fb
+DIST python-zaqarclient-1.13.1.tar.gz 88428 BLAKE2B 71870c7232d4f00b626421fc41e033925fe58f0699538d3e7f3deba2ac07e692d8e676eb763429efcc16ca0c39f8a15317106ca8f6ade583555a89495eba324c SHA512 4854e0a90e98d8172058316fbfcefc0a327a81ae870db28a51264b8e4b809383b652818506f734dd2b35648a544d0811046957c97a86f12d696021d54fbfa890
diff --git a/dev-python/python-zaqarclient/python-zaqarclient-1.13.1.ebuild b/dev-python/python-zaqarclient/python-zaqarclient-1.13.1.ebuild
new file mode 100644 (file)
index 0000000..afb54cd
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Zaqar API"
+HOMEPAGE="https://github.com/openstack/python-zaqarclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+       >=dev-python/jsonschema-2.6.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+       >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+       >=dev-python/keystoneauth-3.4.0[${PYTHON_USEDEP}]
+       >=dev-python/osc-lib-1.8.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+       # built in...
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}