dev-python/pyserial: Remove old
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 13:32:16 +0000 (14:32 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 13:58:53 +0000 (14:58 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyserial/Manifest
dev-python/pyserial/pyserial-3.2.1.ebuild [deleted file]

index a4dbc05dd281dcc979a80e8f78942eb13caf539c..0dddf76c59236bd29bb79930b5390bc4b11844f1 100644 (file)
@@ -1,2 +1 @@
-DIST pyserial-3.2.1.tar.gz 147338 BLAKE2B 6c377d1527183fc48e1369f206f409d312e4488bdb15ae1d1ed93249073ffc56529a9e6059ef57c8f2ebb867cb6d9c0b7dc3a74eafbf653463a05e603b25d69c SHA512 8d3e580cc7781fc6549ab6e408642f4321eb90aafbe593f5dcf953001730f89ee32ce6592728764027a7944bfe4a0ebe2cfac1fce071777aac7c4f27ac94ab7f
 DIST pyserial-3.4.tar.gz 151657 BLAKE2B cf47aba4a6f3bb2fe39d99e72907496faa1c9f37857810fef4d826cca72c361d0e43dbc33d9cf2291a589bf0193d17355d149e6eb61b4f9e28250207708ef09a SHA512 d71dffc330704e41caac6054adf192bee2f1c119691faf2ea93fe22e8e3ba000dc4a1434293f6f80d05a5577d85b96791f656e28d5c63fb0ce6a6605467a117f
diff --git a/dev-python/pyserial/pyserial-3.2.1.ebuild b/dev-python/pyserial/pyserial-3.2.1.ebuild
deleted file mode 100644 (file)
index 2e7cc80..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python Serial Port extension"
-HOMEPAGE="https://github.com/pyserial/pyserial https://pypi.org/project/pyserial/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
-IUSE="doc examples"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-# Usual avoid d'loading un-needed objects.inv file
-PATCHES=( "${FILESDIR}"/mapping.patch )
-
-DOCS=( CHANGES.rst README.rst )
-
-python_compile_all() {
-       use doc && emake -C documentation html
-}
-
-python_test() {
-       ${EPYTHON} test/run_all_tests.py || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( documentation/_build/html/. )
-       distutils-r1_python_install_all
-       if use examples; then
-               insinto /usr/share/doc/${PF}
-               doins -r examples
-               docompress -x /usr/share/doc/${PF}/examples
-       fi
-}