use src_compile, fixes #151387
authorJohn N. Laliberte <allanonjl@gentoo.org>
Tue, 31 Oct 2006 20:33:03 +0000 (20:33 +0000)
committerJohn N. Laliberte <allanonjl@gentoo.org>
Tue, 31 Oct 2006 20:33:03 +0000 (20:33 +0000)
Package-Manager: portage-2.1.2_pre3-r8

app-text/iso-codes/ChangeLog
app-text/iso-codes/iso-codes-0.49-r1.ebuild
app-text/iso-codes/iso-codes-0.49.ebuild

index fe718837228028cb41e646b1b11146c6b9819600..bc65a13653793e978541cf738bfd9542ff520e0b 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for app-text/iso-codes
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.21 2006/06/18 14:51:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.22 2006/10/31 20:33:03 allanonjl Exp $
+
+  31 Oct 2006; John N. Laliberte <allanonjl@gentoo.org>
+  -iso-codes-0.47.ebuild, -iso-codes-0.47-r1.ebuild, iso-codes-0.49.ebuild,
+  iso-codes-0.49-r1.ebuild:
+  use src_compile, fixes #151387
 
   18 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
   +files/iso-codes-0.49-bsd-install.patch, iso-codes-0.49-r1.ebuild:
index 5f1314aaa663cc3fa8f6f6d706a12ad5a6ab810a..0b44b6082dad97015dcba87249b4aba6a736b547 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-0.49-r1.ebuild,v 1.4 2006/10/14 21:01:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-0.49-r1.ebuild,v 1.5 2006/10/31 20:33:03 allanonjl Exp $
 
 inherit eutils autotools
 
@@ -19,7 +19,7 @@ DEPEND="sys-devel/gettext
        >=sys-devel/automake-1.9"
 
 src_unpack() {
-       unpack ${A}
+       unpack "${A}"
        cd "${S}"
 
        # patch to fix up version reporting (bug #118240)
@@ -35,8 +35,11 @@ src_unpack() {
        eautomake
 }
 
-src_install() {
+src_compile() {
        econf || die "configure failed"
+}
+
+src_install() {
        make DESTDIR="${D}" install || die "Installation failed"
 
        dodoc ChangeLog README TODO
index 3c45a9d00c691da03ce3f12df04a1280d56d2648..3c4772897bfe1b5c7714d64ec7902d7f0cd5be14 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-0.49.ebuild,v 1.12 2006/10/14 21:01:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-0.49.ebuild,v 1.13 2006/10/31 20:33:03 allanonjl Exp $
 
 inherit autotools
 
@@ -19,16 +19,19 @@ DEPEND="sys-devel/gettext
                >=sys-devel/automake-1.9"
 
 src_unpack() {
-       unpack ${A}
-       cd ${S}
+       unpack "${A}"
+       cd "${S}"
        sed -i -e 's:(datadir)/pkgconfig:(libdir)/pkgconfig:g' Makefile.am
        eaclocal
        eautoconf
        eautomake
 }
 
-src_install() {
+src_compile() {
        econf || die "configure failed"
+}
+
+src_install() {
        make DESTDIR="${D}" install || die "Installation failed"
 
        dodoc ChangeLog README TODO