dev-python/python-novaclient: 13.0.2 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 12 Nov 2019 19:47:56 +0000 (13:47 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 12 Nov 2019 19:53:30 +0000 (13:53 -0600)
Package-Manager: Portage-2.3.76, Repoman-2.3.18
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/python-novaclient/Manifest
dev-python/python-novaclient/python-novaclient-13.0.2.ebuild [new file with mode: 0644]

index 3f3a0f587291ef1b389c7e852d1fe15363c05e4d..fbbbf45c863429dfec61509b97fc9756b7b4374e 100644 (file)
@@ -1 +1,2 @@
 DIST python-novaclient-13.0.1.tar.gz 312975 BLAKE2B 8f512a6b9e84e352d77f82b81777f1f9d9c8c6b40e86639c9400dede461c7f61d222ea304b8f407cf1775558aa3efe2519e03ee7ee83b17d80d5a7fa0e965284 SHA512 cca8eab5a11a784d5b701a128125e5de25c802081defa61df99449cbd711b0d6913dafeceb28e452fd9a33f901e04b5875b9cd641622af5ac6f06c00c30f7bba
+DIST python-novaclient-13.0.2.tar.gz 312390 BLAKE2B 2a436a2f843afe466bbf3d376d16a994f25e2232dfcb67271837159c5f21d7970027ad6d946c331dd6bff5c248d6b526303205a96a18ef4872cc8b1b526ff366 SHA512 988264cb6b6034dd0c4cb3a79840f591bda9c1c0134ddf0124beea6d9992192dbaeb9ec20bbe73f5a831bf561d175fd3d312880093f58de51d326922502cd1e5
diff --git a/dev-python/python-novaclient/python-novaclient-13.0.2.ebuild b/dev-python/python-novaclient/python-novaclient-13.0.2.ebuild
new file mode 100644 (file)
index 0000000..5c078c7
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Nova API"
+HOMEPAGE="https://github.com/openstack/python-novaclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       test? (
+               >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+               >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+               !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+               >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+               >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+               >=dev-python/keyring-5.5.1[${PYTHON_USEDEP}]
+               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+               >=dev-python/python-cinderclient-3.3.0[${PYTHON_USEDEP}]
+               >=dev-python/python-glanceclient-2.8.0[${PYTHON_USEDEP}]
+               >=dev-python/python-neutronclient-6.7.0[${PYTHON_USEDEP}]
+               >=dev-python/requests-mock-1.1[${PYTHON_USEDEP}]
+               >=dev-python/openstacksdk-0.11.2[${PYTHON_USEDEP}]
+               >=dev-python/osprofiler-1.4.0[${PYTHON_USEDEP}]
+               >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+               >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+       )"
+RDEPEND="
+       >=dev-python/keystoneauth-3.5.0[${PYTHON_USEDEP}]
+       >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+       >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+       >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+       !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+       >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+       >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
+       <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+       !~dev-python/requests-2.12.2[${PYTHON_USEDEP}]
+       >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+       >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+       >=dev-python/Babel-2.4.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+       # built in...
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       testr init
+       testr run --parallel || die "testsuite failed under python2.7"
+}