app-emulation/ganeti: Add patch to make build system respect HCFLAGS
authorPatrick McLean <chutzpah@gentoo.org>
Wed, 31 Jan 2018 00:33:26 +0000 (16:33 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 31 Jan 2018 00:33:26 +0000 (16:33 -0800)
Package-Manager: Portage-2.3.21, Repoman-2.3.6

app-emulation/ganeti/files/ganeti-2.15-respect-HFLAGS.patch [new file with mode: 0644]
app-emulation/ganeti/ganeti-2.15.2-r6.ebuild
app-emulation/ganeti/ganeti-2.16.0_rc1.ebuild

diff --git a/app-emulation/ganeti/files/ganeti-2.15-respect-HFLAGS.patch b/app-emulation/ganeti/files/ganeti-2.15-respect-HFLAGS.patch
new file mode 100644 (file)
index 0000000..ffab183
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/Makefile.am b/Makefile.am
+index a04b95ae3..e26508ad9 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -803,6 +803,7 @@ HFLAGS = \
+       -fwarn-tabs \
+       -optP-include -optP$(HASKELL_PACKAGE_VERSIONS_FILE) \
+       -hide-all-packages \
++      $(HCFLAGS) \
+       `cat $(HASKELL_PACKAGE_IDS_FILE)` \
+       $(GHC_BYVERSION_FLAGS)
+ if DEVELOPER_MODE
index 739b9186e2deb48c604c313c321d919a05d66dc4..cb14808fba4d27899393bd21d0852e5cab904549 100644 (file)
@@ -177,6 +177,7 @@ PATCHES+=(
        "${FILESDIR}/${PN}-2.15-noded-must-run-as-root.patch"
        "${FILESDIR}/${PN}-2.15-kvmd-run-as-daemon-user.patch"
        "${FILESDIR}/${PN}-2.15-dont-invert-return-values-for-man-warnings.patch"
+       "${FILESDIR}/${PN}-2.15-respect-HFLAGS.patch"
 )
 
 S="${WORKDIR}/${MY_P}"
index 5aee625621fcfd147fe2a325b5b96868f5db81d5..735e13c59f49bd68f15f6ff0cca616434fe65084 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -183,6 +183,7 @@ PATCHES+=(
        "${FILESDIR}/${PN}-2.16-kvmd-run-as-daemon-user.patch"
        "${FILESDIR}/${PN}-2.15-dont-invert-return-values-for-man-warnings.patch"
        "${FILESDIR}/fix_ftbfs_with_sphinx_1.4"
+       "${FILESDIR}/${PN}-2.15-respect-HFLAGS.patch"
 )
 
 S="${WORKDIR}/${MY_P}"