dev-python/httpretty: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 09:29:11 +0000 (11:29 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 09:36:48 +0000 (11:36 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/httpretty/Manifest
dev-python/httpretty/httpretty-0.9.7.ebuild [deleted file]

index 54077ea86c6d2c0fabc95896f5d833499cce3a1d..942fa7ec9ec44dc0e2e19bc0e9f6635ca16d83da 100644 (file)
@@ -1,3 +1,2 @@
 DIST httpretty-0.9.6.tar.gz 7147633 BLAKE2B e1d02ddfce5ca987c6ef1a17723544f86a8573c2a6a26ec197072021e52015efce5064af21bfbe1ec03f3ac11c21717a80f114b5be2526b113e3bc0a608702f4 SHA512 bc1c64d34370209c732bc12dd9935600b647507ab2c8f18c85f348e9b5e853618ba39e10e5a073b35036e6cbe3db2cb7a342a721d0e4affa81fe178fd0b75d92
-DIST httpretty-0.9.7.tar.gz 6967749 BLAKE2B e2192871ca4f0f0c0bc7c39570251d26a6d78b6e5aabb1857df2b5c3533ae066400fca323d53e1790bfa2a1509e8ebb87d20d49659620087ca3c3765648662ec SHA512 4a1cdfc09af14ab2bc6eec84ad0905103ffb48c3154b127f646b39ff131584a52b1fd56bfe7a41959fc68d64eff94a221f9bf5a159a3dbfb3535fe4ac76c6170
 DIST httpretty-1.0.2.tar.gz 399185 BLAKE2B 033e954fccf6a351c09dac3c1585ddc65f064eca109dfd8f499fd510ea09ba3ce5198d3f4b54fb832b47425ab721ddc1b2da596b6066028bda1f0a1303cdc0ed SHA512 f9ef1c82f4fe3a31696e06228cea512664c5118b3c32910d7810d1fcf16b05d31b9b55db7bb6bd64967aadb162a2952757627439769db9117164b8248de9049c
diff --git a/dev-python/httpretty/httpretty-0.9.7.ebuild b/dev-python/httpretty/httpretty-0.9.7.ebuild
deleted file mode 100644 (file)
index 5488641..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP client mock for Python"
-HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/six[${PYTHON_USEDEP}]
-       dev-python/urllib3[${PYTHON_USEDEP}]"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               >=dev-python/nose-1.2[${PYTHON_USEDEP}]
-               >=dev-python/mock-1.0[${PYTHON_USEDEP}]
-               dev-python/sure[${PYTHON_USEDEP}]
-               dev-python/httplib2[${PYTHON_USEDEP}]
-               >=dev-python/requests-1.1[${PYTHON_USEDEP}]
-               >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
-)"
-
-python_prepare_all() {
-       # remove useless deps
-       sed -i -e '/randomly/d' -e '/rednose/d' setup.cfg || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       nosetests -v tests || die "Tests fail with ${EPYTHON}"
-}