app-eselect/eselect-mpost: port to EAPI=7
authorMikle Kolyada <zlogene@gentoo.org>
Fri, 25 Oct 2019 08:20:15 +0000 (11:20 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Fri, 25 Oct 2019 08:20:48 +0000 (11:20 +0300)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
app-eselect/eselect-mpost/eselect-mpost-0.3.ebuild

index 6d9ef0a7e944ca202cf8d2c29597ccbbf594bb57..f715cb4b8850492b647eb14ebaa71d9504eabd87 100644 (file)
@@ -1,12 +1,10 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
-
-inherit eutils
+EAPI=7
 
 DESCRIPTION="mpost module for eselect"
-HOMEPAGE="https://www.gentoo.org/proj/en/eselect/"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:TeX"
 SRC_URI=""
 
 LICENSE="GPL-2"
@@ -20,11 +18,12 @@ DEPEND=""
 RDEPEND=">=app-admin/eselect-1.2.3
        >=app-text/texlive-core-2008"
 
+S="${WORKDIR}"
+
 src_install() {
        local MODULEDIR="/usr/share/eselect/modules"
        local MODULE="mpost"
        dodir ${MODULEDIR}
        insinto ${MODULEDIR}
-       newins "${FILESDIR}/${MODULE}.eselect-${PVR}" ${MODULE}.eselect \
-               || die "failed to install"
+       newins "${FILESDIR}/${MODULE}.eselect-${PVR}" ${MODULE}.eselect
 }