dev-util/eric: Switch to PYTHON_MULTI_USEDEP API
authorMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 13:01:25 +0000 (14:01 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 9 Feb 2020 16:21:32 +0000 (17:21 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/eric/eric-18.03.ebuild
dev-util/eric/eric-19.11-r1.ebuild [moved from dev-util/eric/eric-19.11.ebuild with 68% similarity]

index 3e51fdbe81d89f69f5f3b0a6633ec978aa6f2185..c67b729ada7704ee69d9cf5cddacae3f7c9cbf7d 100644 (file)
@@ -19,18 +19,22 @@ IUSE=""
 
 DEPEND="
        ${PYTHON_DEPS}
-       >=dev-python/sip-4.14.3[${PYTHON_USEDEP}]
-       >=dev-python/PyQt5-5.7.1[gui,network,printsupport,sql,svg,widgets,${PYTHON_USEDEP}]
-       >=dev-python/qscintilla-python-2.10[qt5(+),${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/sip-4.14.3[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/PyQt5-5.7.1[gui,network,printsupport,sql,svg,widgets,${PYTHON_MULTI_USEDEP}]
+               >=dev-python/qscintilla-python-2.10[qt5(+),${PYTHON_MULTI_USEDEP}]
+       ')
 "
 RDEPEND="${DEPEND}
-       || (
-               dev-python/PyQt5[help,webengine,${PYTHON_USEDEP}]
-               dev-python/PyQt5[help,webkit,${PYTHON_USEDEP}]
-       )
-       >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
-       >=dev-python/coverage-4.1.0[${PYTHON_USEDEP}]
-       >=dev-python/pygments-2.2.0[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               || (
+                       dev-python/PyQt5[help,webengine,${PYTHON_MULTI_USEDEP}]
+                       dev-python/PyQt5[help,webkit,${PYTHON_MULTI_USEDEP}]
+               )
+               >=dev-python/chardet-3.0.4[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/coverage-4.1.0[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/pygments-2.2.0[${PYTHON_MULTI_USEDEP}]
+       ')
        !dev-util/eric:4
        !dev-util/eric:5
 "
similarity index 68%
rename from dev-util/eric/eric-19.11.ebuild
rename to dev-util/eric/eric-19.11-r1.ebuild
index 425d51c2062c01cbd29b806348df1c08a205741a..bb8cee447042b8981aa052567459402bb39497be 100644 (file)
@@ -20,15 +20,19 @@ IUSE="spell"
 
 DEPEND="
        ${PYTHON_DEPS}
-       >=dev-python/PyQt5-5.12[gui,help,network,printsupport,sql,svg,widgets,${PYTHON_USEDEP}]
-       dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
-       dev-python/qscintilla-python[${PYTHON_USEDEP}]
-       dev-python/sip[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep '
+               >=dev-python/PyQt5-5.12[gui,help,network,printsupport,sql,svg,widgets,${PYTHON_MULTI_USEDEP}]
+               dev-python/PyQtWebEngine[${PYTHON_MULTI_USEDEP}]
+               dev-python/qscintilla-python[${PYTHON_MULTI_USEDEP}]
+               dev-python/sip[${PYTHON_MULTI_USEDEP}]
+       ')
 "
 RDEPEND="${DEPEND}
-       >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
-       >=dev-python/pygments-2.3.1[${PYTHON_USEDEP}]
-       spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )
+       $(python_gen_cond_dep '
+               >=dev-python/chardet-3.0.4[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/pygments-2.3.1[${PYTHON_MULTI_USEDEP}]
+               spell? ( dev-python/pyenchant[${PYTHON_MULTI_USEDEP}] )
+       ')
 "
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"