dev-python/socketpool: Backport py39 to -r2
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 18:14:59 +0000 (20:14 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 18:31:54 +0000 (20:31 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/socketpool/socketpool-0.5.3-r2.ebuild

index c1a63b20d0a76ffffa48dcd07d1b504fd1dbdc39..e0fffe7af7aedc15b1daaee66e8fe10742f9af26 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
 
 inherit distutils-r1
 
@@ -36,6 +36,13 @@ PATCHES=( "${FILESDIR}"/${PN}-0.5.2-locale.patch )
 
 distutils_enable_tests pytest
 
+src_prepare() {
+       # py3.9
+       sed -i -e 's:isAlive:is_alive:' socketpool/backend_thread.py || die
+
+       distutils-r1_src_prepare
+}
+
 python_test() {
        cp -r examples tests "${BUILD_DIR}" || die