app-emulation/docker-runc: Initial version (docker-fork of runc)
authorManuel Rüger <mrueg@gentoo.org>
Fri, 24 Feb 2017 10:25:19 +0000 (11:25 +0100)
committerManuel Rüger <mrueg@gentoo.org>
Fri, 24 Feb 2017 10:25:19 +0000 (11:25 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-emulation/docker-runc/Manifest [new file with mode: 0644]
app-emulation/docker-runc/docker-runc-1.0.0_rc2_p20170201.ebuild [new file with mode: 0644]
app-emulation/docker-runc/metadata.xml [new file with mode: 0644]

diff --git a/app-emulation/docker-runc/Manifest b/app-emulation/docker-runc/Manifest
new file mode 100644 (file)
index 0000000..e3ee173
--- /dev/null
@@ -0,0 +1 @@
+DIST docker-runc-1.0.0_rc2_p20170201.tar.gz 560793 SHA256 11f69923a786efb82b65d9f1eec0ac665a985e631a67f3f4d466dac720efacdd SHA512 8c19a02a55108cef36cbd1ff739a3c8e2962d188c426517fce91483ec525546d39c14072f0a0f2471b6b70a05cf6c1f0e99cfeb5e87203fcbae955bd5f5bd16b WHIRLPOOL 8a1f44234c668aca5c53e401ce80e2c297ad9c7ed0b10d782494e93020f824e6d5e3a00be221f1ff5d039df998c43556228503788181a45256d91278dd005721
diff --git a/app-emulation/docker-runc/docker-runc-1.0.0_rc2_p20170201.ebuild b/app-emulation/docker-runc/docker-runc-1.0.0_rc2_p20170201.ebuild
new file mode 100644 (file)
index 0000000..d6ffc9f
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+EGO_PN="github.com/docker/${PN/docker-}"
+
+if [[ ${PV} == *9999 ]]; then
+       inherit golang-vcs
+else
+       MY_PV="${PV/_/-}"
+       EGIT_COMMIT="9df8b306d01f59d3a8029be411de015b7304dd8f"
+       RUNC_COMMIT="9df8b3" # Change this when you update the ebuild
+       SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~ppc64"
+       inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="runc container cli tools (docker fork)"
+HOMEPAGE="http://runc.io"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="apparmor hardened +seccomp"
+
+RDEPEND="
+       apparmor? ( sys-libs/libapparmor )
+       seccomp? ( sys-libs/libseccomp )
+       !app-emulation/runc
+"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="test"
+
+src_compile() {
+       # Taken from app-emulation/docker-1.7.0-r1
+       export CGO_CFLAGS="-I${ROOT}/usr/include"
+       export CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')
+               -L${ROOT}/usr/$(get_libdir)"
+
+       # Setup GOPATH so things build
+       rm -rf .gopath
+       mkdir -p .gopath/src/"$(dirname "${GITHUB_URI}")"
+       ln -sf ../../../.. .gopath/src/"${GITHUB_URI}"
+       export GOPATH="${PWD}/.gopath:${PWD}/vendor"
+
+       # build up optional flags
+       local options=(
+               $(usex apparmor 'apparmor')
+               $(usex seccomp 'seccomp')
+       )
+
+       emake BUILDTAGS="${options[*]}" \
+               COMMIT="${RUNC_COMMIT}"
+}
+
+src_install() {
+       dobin runc
+}
diff --git a/app-emulation/docker-runc/metadata.xml b/app-emulation/docker-runc/metadata.xml
new file mode 100644 (file)
index 0000000..4a3ebf6
--- /dev/null
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <longdescription lang="en">
+               runc is a CLI tool for spawning and running containers according
+               to the OCF (Open Container Format) specification.
+       </longdescription>
+       <maintainer type="person">
+               <email>mrueg@gentoo.org</email>
+               <name>Manuel Rüger</name>
+       </maintainer>
+       <use>
+               <flag name="apparmor">
+                       Enable AppArmor support.
+               </flag>
+       </use>
+       <upstream>
+               <remote-id type="github">docker/runc</remote-id>
+       </upstream>
+</pkgmetadata>