games-misc/cowsay: bump to 3.04
authorWim Muskee <wimmuskee@gmail.com>
Sat, 19 Oct 2019 07:12:53 +0000 (09:12 +0200)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 20 Oct 2019 11:26:32 +0000 (12:26 +0100)
Closes: https://bugs.gentoo.org/680466
Signed-off-by: Wim Muskee <wimmuskee@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/13338
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-misc/cowsay/Manifest
games-misc/cowsay/cowsay-3.04.ebuild [new file with mode: 0644]
games-misc/cowsay/files/cowsay-3.04-mech.patch [new file with mode: 0644]
games-misc/cowsay/files/cowsay-3.04-tongue.patch [new file with mode: 0644]
games-misc/cowsay/files/cowsay-3.04-utf8.patch [new file with mode: 0644]
games-misc/cowsay/files/cowsay-3.04-version.patch [new file with mode: 0644]
games-misc/cowsay/metadata.xml

index a73b46fb877adf7a316769aa6a509cd23f65fddc..3669e1b5aa2f7c4db3018cc02d37f7ee5866e658 100644 (file)
@@ -1 +1,2 @@
 DIST cowsay-3.03.tar.gz 15189 BLAKE2B de22c870c23612d1861d7de5e610a072833f1627897b11bb9a642464032051a35f6a146125a75c511e7b65df3f885cb7558988d0a535e093dcb3765969aef4d1 SHA512 8e91d0c929c2e0743106c08643029a943d0684343ff44ad8ff172636a8f47fd25ee8bc4d108ccfe308c756d2871b956cceef0c406800615ed0dc1e1e24648219
+DIST cowsay-3.04.tar.gz 31961 BLAKE2B 93e6e9cb31b8902ee6bccda0f997fa651fa83e0504ccab3e7fbbc5cfddc11256f6adea1ea1b4e2bcf8085746eb4194e8332bfee886d1f3d05ad2b6ac3422eea8 SHA512 99d21ef9a7c7c76056cb7acb2c771fbdabfedde4f6edb5d3035337c59f9e88944690d1b43282c32827ad79339199716366c8be73b0dea09063ec2d52220c1b51
diff --git a/games-misc/cowsay/cowsay-3.04.ebuild b/games-misc/cowsay/cowsay-3.04.ebuild
new file mode 100644 (file)
index 0000000..2186ca0
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Configurable talking ASCII cow (and other characters)"
+HOMEPAGE="https://github.com/tnalpgge/rank-amateur-cowsay"
+SRC_URI="https://github.com/tnalpgge/rank-amateur-${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc64 ~x86 ~x64-solaris"
+
+RDEPEND=">=dev-lang/perl-5"
+BDEPEND="${RDEPEND}"
+PATCHES=(
+       "${FILESDIR}/${P}-tongue.patch"
+       "${FILESDIR}/${P}-mech.patch"
+       "${FILESDIR}/${P}-utf8.patch"
+       "${FILESDIR}/${P}-version.patch" )
+
+S="${WORKDIR}/rank-amateur-${PN}-${P}"
+
+src_prepare() {
+       sed     -i \
+               -e "1 c\#!${EPREFIX}/usr/bin/perl"\
+               -e 's/\$version/\$VERSION/g'\
+               -e "s:%PREFIX%/share/cows:${EPREFIX}/usr/share/${P}/cows:" \
+               -e '/getopts/ i\$Getopt::Std::STANDARD_HELP_VERSION=1;' cowsay \
+                       || die "sed cowsay failed"
+       sed -i \
+               -e "s|%PREFIX%/share/cows|${EPREFIX}/usr/share/${P}/cows|" cowsay.1 \
+                       || die "sed cowsay.1 failed"
+
+       default
+}
+
+src_compile() {
+       ./install.sh "${D}"
+}
+
+src_install() {
+       dobin cowsay
+       doman cowsay.1
+       dosym cowsay /usr/bin/cowthink
+       dosym cowsay.1 /usr/share/man/man1/cowthink.1
+       insinto /usr/share/${P}
+       doins -r cows
+       einstalldocs
+}
diff --git a/games-misc/cowsay/files/cowsay-3.04-mech.patch b/games-misc/cowsay/files/cowsay-3.04-mech.patch
new file mode 100644 (file)
index 0000000..9c9ff9d
--- /dev/null
@@ -0,0 +1,18 @@
+--- rank-amateur-cowsay-cowsay-3.04/cows/mech-and-cow  2009-06-21 03:09:36.000000000 +0300
++++ rank-amateur-cowsay-cowsay-3.04/cows/mech-and-cow.cow      2010-08-22 01:04:02.670000262 +0300
+@@ -1,3 +1,5 @@
++$the_cow = <<EOC;
++${thouts}
+                                    ,-----.
+                                    |     |
+                                 ,--|     |-.
+@@ -14,8 +16,4 @@
+    (__)\       )\/\             /'    /   |   `i
+        ||----w |           ___,;`----'.___L_,-'`\__
+        ||     ||          i_____;----\.____i""\____\
+-
+-
+-
+-
+-
++EOC
diff --git a/games-misc/cowsay/files/cowsay-3.04-tongue.patch b/games-misc/cowsay/files/cowsay-3.04-tongue.patch
new file mode 100644 (file)
index 0000000..0112358
--- /dev/null
@@ -0,0 +1,10 @@
+--- rank-amateur-cowsay-cowsay-3.04/cows/head-in.cow.old       2007-05-09 20:28:08.000000000 +0200
++++ rank-amateur-cowsay-cowsay-3.04/cows/head-in.cow   2007-05-09 20:29:32.000000000 +0200
+@@ -7,6 +7,6 @@
+     ^__^         /
+     ($eyes)\\_______/  _________
+     (__)\\       )=(  ____|_ \\_____
+-   $tongue   ||----w |  \\ \\     \\_____ |
++     $tongue ||----w |  \\ \\     \\_____ |
+         ||     ||   ||           ||
+ EOC
diff --git a/games-misc/cowsay/files/cowsay-3.04-utf8.patch b/games-misc/cowsay/files/cowsay-3.04-utf8.patch
new file mode 100644 (file)
index 0000000..3aeaf0d
--- /dev/null
@@ -0,0 +1,17 @@
+diff -Naur cowsay-3.03.orig//cowsay cowsay-3.03/cowsay
+--- rank-amateur-cowsay-cowsay-3.04/cowsay.orig        2011-04-21 16:36:03.581377699 +0200
++++ rank-amateur-cowsay-cowsay-3.04/cowsay     2011-04-21 16:37:07.968430100 +0200
+@@ -12,6 +12,13 @@
+ use Getopt::Std;
+ use Cwd;
++if (${^UTF8LOCALE}) {
++    binmode STDIN, ':utf8';
++    binmode STDOUT, ':utf8';
++    require Encode;
++    eval { $_ = Encode::decode_utf8($_,1) } for @ARGV;
++}
++
+ $VERSION = "3.03";
+ $progname = basename($0);
+ $eyes = "oo";
diff --git a/games-misc/cowsay/files/cowsay-3.04-version.patch b/games-misc/cowsay/files/cowsay-3.04-version.patch
new file mode 100644 (file)
index 0000000..4b8c474
--- /dev/null
@@ -0,0 +1,20 @@
+--- rank-amateur-cowsay-cowsay-3.04/cowsay.orig        2019-10-19 08:44:59.442928870 +0200
++++ rank-amateur-cowsay-cowsay-3.04/cowsay     2019-10-19 08:45:16.165928638 +0200
+@@ -1,7 +1,7 @@
+ #!/usr/bin/perl
+ ##
+-## Cowsay 3.03
++## Cowsay 3.04
+ ##
+ ## This file is part of cowsay.  (c) 1999-2000 Tony Monroe.
+ ##
+@@ -19,7 +19,7 @@
+     eval { $_ = Encode::decode_utf8($_,1) } for @ARGV;
+ }
+-$VERSION = "3.03";
++$VERSION = "3.04";
+ $progname = basename($0);
+ $eyes = "oo";
+ $tongue = "  ";
index 78274e0fa550cc9c38545b42c2aba5e165c0d8ba..69b606b9aed3bd3e3c1e04d6b5b10edede623cfc 100644 (file)
@@ -5,4 +5,7 @@
        <email>games@gentoo.org</email>
        <name>Gentoo Games Project</name>
 </maintainer>
+<upstream>
+       <remote-id type="github">tnalpgge/rank-amateur-cowsay</remote-id>
+</upstream>
 </pkgmetadata>