dev-libs/libnl: Update live ebuild
authorJeroen Roovers <jer@gentoo.org>
Mon, 14 Oct 2019 08:52:58 +0000 (10:52 +0200)
committerJeroen Roovers <jer@gentoo.org>
Mon, 14 Oct 2019 08:53:13 +0000 (10:53 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
dev-libs/libnl/libnl-99999999.ebuild

index 43eb90b83be5ea5a9020a110b09696336e3f77c6..bb976be451389c41e8b41285a3525b102b9f0197 100644 (file)
@@ -1,10 +1,10 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6} )
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
 DISTUTILS_OPTIONAL=1
-inherit autotools distutils-r1 eutils git-r3 libtool multilib multilib-minimal
+inherit autotools distutils-r1 git-r3 libtool multilib multilib-minimal
 
 DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
 HOMEPAGE="http://www.infradead.org/~tgr/libnl/ https://github.com/thom311/libnl"
@@ -84,7 +84,7 @@ multilib_src_compile() {
 }
 
 multilib_src_install() {
-       emake DESTDIR="${D}" install
+       default
 
        if multilib_is_native_abi && use python; then
                # Unset DOCS= since distutils-r1.eclass interferes
@@ -96,5 +96,5 @@ multilib_src_install() {
 
 multilib_src_install_all() {
        einstalldocs
-       prune_libtool_files --modules
+       find "${D}" -name '*.la' -delete || die
 }