net-fs/samba: Added "--no-run-if-empty" to xargs call.
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 9 Jul 2019 16:02:29 +0000 (18:02 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 9 Jul 2019 16:02:48 +0000 (18:02 +0200)
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-fs/samba/samba-4.10.6.ebuild

index 88714ea14ee9a2e419a5078cb706aaa23ef27c32..3d065562f7cc04d6a1d9409c23210ed4a22c26b5 100644 (file)
@@ -293,7 +293,8 @@ multilib_src_install() {
 
 multilib_src_install_all() {
        # Attempt to fix bug #673168
-       find "${ED}" -type d -name "Yapp" -print0 | xargs -0 rm -r || die
+       find "${ED}" -type d -name "Yapp" -print0 \
+               | xargs -0 --no-run-if-empty rm -r || die
 }
 
 multilib_src_test() {