media-video/ffmpeg: add Prefix keywords and Solaris fix, bug #612366
authorFabian Groffen <grobian@gentoo.org>
Mon, 20 Mar 2017 20:24:24 +0000 (21:24 +0100)
committerFabian Groffen <grobian@gentoo.org>
Mon, 20 Mar 2017 20:24:35 +0000 (21:24 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

media-video/ffmpeg/ffmpeg-3.2.4.ebuild

index 9e611292a7b682d9c8cb33f125c3ba9f232c9ab5..ef8ed6df468e987893f35599fa5147968eb9bac1 100644 (file)
@@ -54,7 +54,7 @@ LICENSE="
        samba? ( GPL-3 )
 "
 if [ "${PV#9999}" = "${PV}" ] ; then
-       KEYWORDS="~alpha amd64 arm hppa ~mips ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+       KEYWORDS="~alpha amd64 arm hppa ~mips ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
 fi
 
 # Options to use as use_enable in the foo[:bar] form.
@@ -292,6 +292,10 @@ src_prepare() {
                export revision=git-N-${FFMPEG_REVISION}
        fi
        default
+
+       # the version script on Solaris causes invalid symbol version problems
+       # we don't want their hacky workarounds, we're having a GNU ld
+       sed -i -e 's/sunos)/sunos) network_extralibs="-lsocket -lnsl"; add_cppflags -D__EXTENSIONS__; enable pic; disable symver ;; no-sunos)/' configure || die
 }
 
 multilib_src_configure() {