sci-physics/lammps: Version bump.
authorNicolas Bock <nicolasbock@gentoo.org>
Thu, 8 Oct 2015 12:31:31 +0000 (06:31 -0600)
committerNicolas Bock <nicolasbock@gentoo.org>
Thu, 8 Oct 2015 12:32:01 +0000 (06:32 -0600)
Package-Manager: portage-2.2.20.1

sci-physics/lammps/Manifest
sci-physics/lammps/lammps-20151005.ebuild [new file with mode: 0644]

index 5562a01f4560afc07c482a293116532862262a5f..9d1cdf065c9c5747f9cee68d41c24a4be15bc086 100644 (file)
@@ -7,4 +7,5 @@ DIST lammps-21Aug15.tar.gz 87096749 SHA256 46f68e7b61e50ab3e790c53cadd82fde7c7aa
 DIST lammps-24Sep15.tar.gz 87307191 SHA256 e03cdeb2b3b6107d98969febea26575c85590603ab4f79d26efc46bac6d6cc60 SHA512 356dd556f845cec456865062375120c0898cef1870617d80b31b0e8e964585140120b21f891cd9b40ecde7aaf43beb34d7b15396830e08273624a9b14da551e4 WHIRLPOOL 667b8aaf927d268c569a192c835b7dbdc80a0f25abb1f2c96007517ea218a69b2816dde4ebe28ca82974d01472c0e1126b67e89a19fb3ef49e4020f3d9c69fba
 DIST lammps-29Aug15.tar.gz 87253305 SHA256 fff69b47c40936d4ccd90a8443ce5bb1bcf4cb449ae06a5822c1b11a2ab2dd67 SHA512 991c56608a3288ebdcd2fb0857c595d42047b5ed0780b6d4ddb98388627499727b6c04fe0eff3e7221238dba2a8601f0b4b4067b5aa5ec2f356b4ee13f6c129c WHIRLPOOL 88da74fa65aeb187330439417512d516fe8adf4a5df4be48fdafafa198e8c4d657ecce7f04f749d77cb2f8a7881ac47f4604cf6bc8eb3ca8b2cbc7988d866a87
 DIST lammps-4Sep15.tar.gz 87259558 SHA256 8652c801e4ce8b6b7d42a6c71f76b68a6e741dc8efb8d7d3dad36b624fe8f150 SHA512 ee730c8bd96e14931192a68c12e4ebde301cc3525b20816d051059f155b70c6edcea7dc2ed911e0b89685d751cd5a74b4bb5eedd6c16a042a2191bf8a9665fc9 WHIRLPOOL 271ac0d74e03d3e3e118a8b2385d98ce3f566ead67f1c329a219c265f886dc267b11be17c2caa52749ebac212bbc7456fba2d0d6ec69cd25815316e601b3360a
+DIST lammps-5Oct15.tar.gz 88451532 SHA256 a76f92ae05b99f9257abf7d79d9365c5743fa5a16b941a5e40f74036c5879211 SHA512 e0a034778cd5e3b9a27c9fc6257f1f7a6a9161732cd83bac2c4b0f82c39d5a6a385bb4640322478bfbe9467afb28b998cd19108b3d4a21e369b80c39a486e065 WHIRLPOOL 291e7820d4736421aeda9a1295854bd7b52d8ca3f14900e9394373410ee5db02ad6ab53991cf4dc8e73328b24fa44659d10693aca7cb48301227299ad622ce31
 DIST lammps-9Sep15.tar.gz 87275742 SHA256 c783be8bf2c2fbef75522b09b4420006d94104f2a60b82f55f7bc255c6163079 SHA512 60fa8c818c72c3c236095c7aa23c2ec30cc3370b6dc14d0c1d9e347772e70c96dab43019092eb93f2327377f1b4cc642416be65d156b1faf934bfa805d228bcf WHIRLPOOL 4a9dbb0f1b493177614646dcef124c723a3b6171d0894fee8b34e9fff7d0962ada0a2a27564338fef6551aaff322f4b50784b98c250555173cba5478cc60e9af
diff --git a/sci-physics/lammps/lammps-20151005.ebuild b/sci-physics/lammps/lammps-20151005.ebuild
new file mode 100644 (file)
index 0000000..5400e87
--- /dev/null
@@ -0,0 +1,267 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit eutils flag-o-matic fortran-2 multilib python-r1
+
+convert_month() {
+       case $1 in
+               01) echo Jan
+                       ;;
+               02) echo Feb
+                       ;;
+               03) echo Mar
+                       ;;
+               04) echo Apr
+                       ;;
+               05) echo May
+                       ;;
+               06) echo Jun
+                       ;;
+               07) echo Jul
+                       ;;
+               08) echo Aug
+                       ;;
+               09) echo Sep
+                       ;;
+               10) echo Oct
+                       ;;
+               11) echo Nov
+                       ;;
+               12) echo Dec
+                       ;;
+               *)  echo unknown
+                       ;;
+       esac
+}
+
+MY_P=${PN}-$((10#${PV:6:2}))$(convert_month ${PV:4:2})${PV:2:2}
+
+DESCRIPTION="Large-scale Atomic/Molecular Massively Parallel Simulator"
+HOMEPAGE="http://lammps.sandia.gov/"
+SRC_URI="http://lammps.sandia.gov/tars/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples gzip lammps-memalign mpi python static-libs"
+
+DEPEND="
+       mpi? (
+               virtual/blas
+               virtual/lapack
+               virtual/mpi
+       )
+       gzip? ( app-arch/gzip )
+       sci-libs/voro++
+       python? ( ${PYTHON_DEPS} )
+       "
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+S="${WORKDIR}/${MY_P}"
+
+lmp_emake() {
+       local LAMMPS_INCLUDEFLAGS
+       LAMMPS_INCLUDEFLAGS="$(usex gzip '-DLAMMPS_GZIP' '')"
+       LAMMPS_INCLUDEFLAGS+="$(usex lammps-memalign ' -DLAMMPS_MEMALIGN=64' '')"
+
+       # The lammps makefile uses CC to indicate the C++ compiler.
+       emake \
+               ARCHIVE=$(tc-getAR) \
+               CC=$(usex mpi "mpic++" "$(tc-getCXX)") \
+               F90=$(usex mpi "mpif90" "$(tc-getFC)") \
+               LINK=$(usex mpi "mpic++" "$(tc-getCXX)") \
+               CCFLAGS="${CXXFLAGS}" \
+               F90FLAGS="${FCFLAGS}" \
+               LINKFLAGS="${LDFLAGS}" \
+               LMP_INC="${LAMMPS_INCLUDEFLAGS}" \
+               MPI_INC=$(usex mpi "" "-I../STUBS") \
+               MPI_PATH=$(usex mpi "" "-L../STUBS") \
+               MPI_LIB=$(usex mpi "" "-lmpi_stubs") \
+               user-atc_SYSLIB="$(usex mpi "$($(tc-getPKG_CONFIG) --libs blas) $($(tc-getPKG_CONFIG) --libs lapack)" '')"\
+               "$@"
+}
+
+lmp_activate_packages() {
+       # Build packages
+       lmp_emake -C src yes-asphere
+       lmp_emake -C src yes-body
+       lmp_emake -C src yes-class2
+       lmp_emake -C src yes-colloid
+       lmp_emake -C src yes-coreshell
+       lmp_emake -C src yes-dipole
+       lmp_emake -C src yes-fld
+       #lmp_emake -C src yes-gpu
+       lmp_emake -C src yes-granular
+       # Need OpenKIM external dependency.
+       #lmp_emake -C src yes-kim
+       # Need Kokkos external dependency.
+       #lmp_emake -C src yes-kokkos
+       lmp_emake -C src yes-kspace
+       lmp_emake -C src yes-manybody
+       lmp_emake -C src yes-mc
+       lmp_emake -C src yes-meam
+       lmp_emake -C src yes-misc
+       lmp_emake -C src yes-molecule
+       #lmp_emake -C src yes-mpiio
+       lmp_emake -C src yes-opt
+       lmp_emake -C src yes-peri
+       lmp_emake -C src yes-poems
+       lmp_emake -C src yes-qeq
+       lmp_emake -C src yes-reax
+       lmp_emake -C src yes-replica
+       lmp_emake -C src yes-rigid
+       lmp_emake -C src yes-shock
+       lmp_emake -C src yes-snap
+       lmp_emake -C src yes-srd
+       lmp_emake -C src yes-voronoi
+       lmp_emake -C src yes-xtc
+
+       if use mpi; then
+               lmp_emake -C src yes-user-atc
+       fi
+       lmp_emake -C src yes-user-eff
+       lmp_emake -C src yes-user-fep
+       use mpi && lmp_emake -C src yes-user-lb
+       lmp_emake -C src yes-user-phonon
+       lmp_emake -C src yes-user-sph
+}
+
+lmp_build_packages() {
+       lmp_emake -C lib/meam -j1 -f Makefile.gfortran
+       lmp_emake -C lib/poems -f Makefile.g++
+       lmp_emake -C lib/reax -j1 -f Makefile.gfortran
+       use mpi && lmp_emake -C lib/atc -f Makefile.g++
+}
+
+lmp_clean_packages() {
+       lmp_emake -C lib/meam -f Makefile.gfortran clean
+       lmp_emake -C lib/poems -f Makefile.g++ clean
+       lmp_emake -C lib/reax -f Makefile.gfortran clean
+       use mpi && lmp_emake -C lib/atc -f Makefile.g++ clean
+}
+
+src_prepare() {
+       # Fix inconsistent use of SHFLAGS.
+       sed -i \
+               -e 's:voronoi_SYSINC\s\+=.*$:voronoi_SYSINC = -I/usr/include/voro++:' \
+               -e 's:voronoi_SYSPATH\s\+=.*$:voronoi_SYSPATH =:' \
+               lib/voronoi/Makefile.lammps || die
+
+       # Fix missing .so name.
+       sed -i \
+               -e 's:SHLIBFLAGS\s\+=\s\+:SHLIBFLAGS = -Wl,-soname,liblammps.so.0 :' \
+               src/MAKE/Makefile.serial || die
+
+       # Fix makefile in tools.
+       sed -i \
+               -e 's:g++:$(CXX) $(CXXFLAGS):' \
+               -e 's:gcc:$(CC) $(CCFLAGS):' \
+               -e 's:ifort:$(FC) $(FCFLAGS):' \
+               tools/Makefile || die
+
+       # Patch python.
+       epatch "${FILESDIR}/lammps-python3-r1.patch"
+       epatch "${FILESDIR}/python-shebang.patch"
+}
+
+src_compile() {
+       # Fix atc...
+       append-cxxflags -I../../src
+
+       # Acticate packages.
+       elog "Activating lammps packages..."
+       lmp_activate_packages
+
+       # Compile stubs for serial version.
+       use mpi || lmp_emake -C src mpi-stubs
+
+       elog "Building packages..."
+       lmp_build_packages
+
+       if use static-libs; then
+               # Build static library.
+               elog "Building static library..."
+               lmp_emake -C src mode=lib serial
+       fi
+
+       # Clean out packages (that's not done by the build system with the clean
+       # target), so we can rebuild the packages with -fPIC.
+       elog "Cleaning packages..."
+       lmp_clean_packages
+
+       # The build system does not rebuild the packages with -fPIC, adding flag
+       # manually.
+       append-cxxflags -fPIC
+       append-fflags -fPIC
+
+       # Compile stubs for serial version.
+       use mpi || lmp_emake -C src mpi-stubs
+
+       elog "Building packages..."
+       lmp_build_packages
+
+       # Build shared library.
+       elog "Building shared library..."
+       lmp_emake -C src mode=shlib serial
+
+       # Compile main executable. The shared library is always built, and
+       # mode=shexe is simply a way to re-use the object files built in the
+       # "shlib" step when linking the executable. The executable is not actually
+       # using the shared library. If we have built the static library, then we
+       # link that into the executable.
+       elog "Linking executable..."
+       if use static-libs; then
+               lmp_emake -C src mode=exe serial
+       else
+               lmp_emake -C src mode=shexe serial
+       fi
+
+       # Compile tools.
+       elog "Building tools..."
+       lmp_emake -C tools binary2txt chain data2xmovie micelle2d
+}
+
+src_install() {
+       use static-libs && newlib.a src/liblammps_serial.a liblammps.a
+       newlib.so src/liblammps_serial.so liblammps.so.0.0.0
+       dosym liblammps.so.0.0.0 /usr/$(get_libdir)/liblammps.so
+       dosym liblammps.so.0.0.0 /usr/$(get_libdir)/liblammps.so.0
+       newbin src/lmp_serial lmp
+       dobin tools/binary2txt
+       dobin tools/chain
+       dobin tools/data2xmovie
+       dobin tools/micelle2d
+       # Don't forget to add header files of optional packages as they are added
+       # to this ebuild. There may also be .mod files from Fortran based
+       # packages.
+       insinto "/usr/include/${PN}"
+       doins -r src/*.h lib/meam/*.mod
+
+       local LAMMPS_POTENTIALS="usr/share/${PN}/potentials"
+       insinto "/${LAMMPS_POTENTIALS}"
+       doins potentials/*
+       echo "LAMMPS_POTENTIALS=${EROOT}${LAMMPS_POTENTIALS}" > 99lammps
+       doenvd 99lammps
+
+       # Install python script.
+       use python && python_foreach_impl python_domodule python/lammps.py
+
+       if use examples; then
+               local LAMMPS_EXAMPLES="/usr/share/${PN}/examples"
+               insinto "${LAMMPS_EXAMPLES}"
+               doins -r examples/*
+       fi
+
+       dodoc README
+       if use doc; then
+               dodoc doc/Manual.pdf
+               dohtml -r doc/*
+       fi
+}