dev-python/louie: Port to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Sun, 15 Jan 2017 13:55:54 +0000 (14:55 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 15 Jan 2017 13:56:11 +0000 (14:56 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-python/louie/louie-1.1-r1.ebuild

index 13357c81a36838fc06afa57b85e9d9abaf24b2a1..307b3a99c1fb98b5c218bf51b071ae4542dd29ac 100644 (file)
@@ -2,17 +2,15 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
-EAPI=5
+EAPI=6
+
 PYTHON_COMPAT=( python2_7 )
 
 inherit distutils-r1
 
-MY_PN="Louie"
-MY_P="${MY_PN}-${PV}"
-
 DESCRIPTION="Signal dispatching mechanism for Python"
 HOMEPAGE="https://pypi.python.org/pypi/Louie"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+SRC_URI="mirror://pypi/L/${PN^}/${P^}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"
@@ -23,7 +21,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/nose[${PYTHON_USEDEP}] )"
 RDEPEND=""
 
-S="${WORKDIR}/${MY_P}"
+S="${WORKDIR}/${P^}"
 
 python_prepare_all() {
        sed -e "/'nose >= 0.8.3'/d" -i setup.py || die "sed failed"