net-firewall/ipt_netflow: version bump
authorSergey Popov <pinkbyte@gentoo.org>
Tue, 20 Mar 2018 13:51:38 +0000 (16:51 +0300)
committerSergey Popov <pinkbyte@gentoo.org>
Tue, 20 Mar 2018 13:51:56 +0000 (16:51 +0300)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

net-firewall/ipt_netflow/Manifest
net-firewall/ipt_netflow/ipt_netflow-2.3.ebuild [new file with mode: 0644]

index d2fd5f95a4627fcc7d6f7ab8c5a8bef6f86cb617..b87114ce0969f79de3e157977e30a3d64cb2c882 100644 (file)
@@ -1 +1,2 @@
 DIST ipt-netflow-2.2.tgz 96697 BLAKE2B 996ad539b6a6a5198a1e4a4a1a51f0610d97fb45740ad9c92e19854f2928eb697ca8fe14625054a05b106eebc345dfe6c235cdf375d1360ef44ff6cf0b03f34a SHA512 a406ab9bd18616414d8c99f427382a075bdb8000d8c40959f5b6d6e577d7eb4dfc7f8b773664a516ec2228d15590f21c3fbd6aa3d4302f6cdf03810e1702af74
+DIST ipt_netflow-2.3.tar.gz 90987 BLAKE2B fbe46583e58e75e3cfe5cc5ad4e8b40d5040d6642f850c560c3e8aa831effa43cba8f25907d32b3b66721f4d5d5bb8579bafa82e4b8d1c9a2225a5c748d08dd9 SHA512 e5ba66da9cae6fb9652e5532383233d433dd30dd16634734860f7e6910e46080e562e2d72c74584a86ead31156cffd4c5c44b438f617a9e5b3e5fdc1470045fc
diff --git a/net-firewall/ipt_netflow/ipt_netflow-2.3.ebuild b/net-firewall/ipt_netflow/ipt_netflow-2.3.ebuild
new file mode 100644 (file)
index 0000000..e534596
--- /dev/null
@@ -0,0 +1,100 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+MY_PN="${PN/_/-}"
+MY_P="${MY_PN}-${PV}"
+inherit linux-info linux-mod toolchain-funcs
+
+DESCRIPTION="Netflow iptables module"
+HOMEPAGE="
+       https://sourceforge.net/projects/ipt-netflow
+       https://github.com/aabc/ipt-netflow
+"
+SRC_URI="https://github.com/aabc/ipt-netflow/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug natevents snmp"
+
+RDEPEND="
+       net-firewall/iptables:0=
+       snmp? ( net-analyzer/net-snmp )
+"
+DEPEND="${RDEPEND}
+       virtual/linux-sources
+       virtual/pkgconfig
+"
+
+# set S before MODULE_NAMES
+S="${WORKDIR}/${MY_P}"
+PATCHES=(
+       # bug #455984
+       "${FILESDIR}/${PN}-2.0-configure.patch"
+)
+
+pkg_setup() {
+       BUILD_TARGETS="all"
+       MODULE_NAMES="ipt_NETFLOW(ipt_netflow:${S})"
+       IPT_LIB="/usr/$(get_libdir)/xtables"
+       local CONFIG_CHECK="~IP_NF_IPTABLES"
+       use debug && CONFIG_CHECK+=" ~DEBUG_FS"
+       use natevents && CONFIG_CHECK+=" NF_CONNTRACK_EVENTS NF_NAT_NEEDED"
+       linux-mod_pkg_setup
+}
+
+src_prepare() {
+       sed -i \
+               -e 's:make -C:$(MAKE) -C:g' \
+               -e 's:gcc -O2:$(CC) $(CFLAGS) $(LDFLAGS):' \
+               -e 's:gcc:$(CC) $(CFLAGS) $(LDFLAGS):' \
+               Makefile.in || die
+
+       # Fix incorrect module version in sources
+       sed -i -e "/IPT_NETFLOW_VERSION/s/2.2/${PV}/" ipt_NETFLOW.c || die
+
+       # Checking for directory is enough
+       sed -i -e 's:-s /etc/snmp/snmpd.conf:-d /etc/snmp:' configure || die
+
+       default
+}
+
+do_conf() {
+       echo ./configure $*
+       ./configure $* ${EXTRA_ECONF} || die 'configure failed'
+}
+
+src_configure() {
+       local IPT_VERSION="$($(tc-getPKG_CONFIG) --modversion xtables)"
+       # this configure script is not based on autotools
+       # ipt-src need to be defined, see bug #455984
+       do_conf \
+               --disable-dkms \
+               --enable-aggregation \
+               --enable-direction \
+               --enable-macaddress \
+               --enable-vlan \
+               --ipt-lib="${IPT_LIB}" \
+               --ipt-src="/usr/" \
+               --ipt-ver="${IPT_VERSION}" \
+               --kdir="${KV_DIR}" \
+               --kver="${KV_FULL}" \
+               $(use debug && echo '--enable-debugfs') \
+               $(use natevents && echo '--enable-natevents') \
+               $(use snmp && echo '--enable-snmp-rules' || echo '--disable-snmp-agent')
+}
+
+src_compile() {
+       emake ARCH="$(tc-arch-kernel)" CC="$(tc-getCC)" all
+}
+
+src_install() {
+       linux-mod_src_install
+       exeinto "${IPT_LIB}"
+       doexe libipt_NETFLOW.so
+       use snmp && emake DESTDIR="${D}" SNMPTGSO="/usr/$(get_libdir)/snmp/dlmod/snmp_NETFLOW.so" sinstall
+       doheader ipt_NETFLOW.h
+       dodoc README*
+}