dev-python/nagiosplugin: bump to 1.3.2, tests are back on PyPI
authorLouis Sautier <sbraz@gentoo.org>
Sun, 10 Nov 2019 02:29:40 +0000 (03:29 +0100)
committerLouis Sautier <sbraz@gentoo.org>
Sun, 10 Nov 2019 02:30:24 +0000 (03:30 +0100)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
dev-python/nagiosplugin/Manifest
dev-python/nagiosplugin/nagiosplugin-1.3.2.ebuild [new file with mode: 0644]

index 34bb82afda9e7489c2a922ef12c3028ef702ef16..5acfa98eea784ccbf6883e1e399b0bcc4cd4374c 100644 (file)
@@ -1,2 +1,3 @@
 DIST nagiosplugin-1.2.4.tar.gz 38290 BLAKE2B 4ebf230122a68919f82da7519e920b485075530cbde235d9f0d7a0f22e65a37c85f3ffe84af100f94ba8cee0a8e350b848d2e35606616808baada75c5abfddd2 SHA512 42c7823445c0dc1f5fedc6b8bed6c5be4e2b5e4c14cfa2cfbd158ae43485baa0fc74b80f9dcbb89bfdb27b984d72201c8a7c330c71d837c0f822603a5f8f7ae3
 DIST nagiosplugin-1.3.1.tar.gz 94568 BLAKE2B b73b4790a9d0eccb47b12f45c0ee2b131d1e1874c299b7717023b40d5d0f5c1dbbac8e3736280917fba5595fa882bbc7eb461158c909345c84117757d39a3ebb SHA512 f809258d972650be13667f4bb03db711686d38de1b4fa6da7dc55b576fa0a9f5a9a47fdccec0bb94ddfd258fe64ec30cd30e054f13f5b811eb24a6e9b0c85917
+DIST nagiosplugin-1.3.2.tar.gz 54262 BLAKE2B af2a8a876105a1ea26671b39d611beaa46303998544adadee3370c6d1b5096fa93160121f89412f3778a2bbc1c3e95606a49413b8f3f0880c9c9ca4e946fb1b8 SHA512 899650852397bffb66ad53843233adec2c91e96656674a9b21c5a02ed97ce4db69c1440d1b88c5799a54745e69b8c05f52188403b5a2fe9050acbd0067806d50
diff --git a/dev-python/nagiosplugin/nagiosplugin-1.3.2.ebuild b/dev-python/nagiosplugin/nagiosplugin-1.3.2.ebuild
new file mode 100644 (file)
index 0000000..cd0ca3c
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A class library for writing nagios-compatible plugins"
+HOMEPAGE="https://github.com/mpounsett/nagiosplugin https://nagiosplugin.readthedocs.io"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+LICENSE="ZPL"
+SLOT="0"
+
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+       )
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+       if use doc; then
+               sphinx-build doc doc/_build/html || die
+               HTML_DOCS=( doc/_build/html/. )
+       fi
+}
+
+python_test() {
+       pytest -vv tests || die "tests failed with ${EPYTHON}"
+}