kde-apps/kcontrol: punt trash handbook.
authorMichael Palimaka <kensington@gentoo.org>
Tue, 1 Sep 2015 16:16:09 +0000 (02:16 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Tue, 1 Sep 2015 16:18:07 +0000 (02:18 +1000)
It collides with kde-apps/kio-extras which can be pulled in for KDE 4 users
via kde-apps/dolphin:5 version bump.

Package-Manager: portage-2.2.20.1

kde-apps/kcontrol/kcontrol-15.08.0-r1.ebuild [new file with mode: 0644]

diff --git a/kde-apps/kcontrol/kcontrol-15.08.0-r1.ebuild b/kde-apps/kcontrol/kcontrol-15.08.0-r1.ebuild
new file mode 100644 (file)
index 0000000..a01b8bc
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kde-runtime"
+inherit kde4-meta
+
+DESCRIPTION="The KDE Control Center"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+       $(add_kdeapps_dep zeroconf-ioslave)
+       || ( $(add_kdebase_dep khotkeys '' 4.11) kde-plasma/khotkeys )
+"
+
+src_prepare() {
+       kde4-meta_src_prepare
+       if use handbook; then
+               sed -i -e "/add_subdirectory(kcm_ssl)/d" doc/kcontrol/CMakeLists.txt || die
+               sed -i -e "/add_subdirectory(trash)/d" doc/kcontrol/CMakeLists.txt || die
+       fi
+}