sys-devel/parity: revbump 2.0.0
authorMichael Haubenwallner <haubi@gentoo.org>
Tue, 10 Mar 2020 15:43:42 +0000 (16:43 +0100)
committerMichael Haubenwallner <haubi@gentoo.org>
Wed, 11 Mar 2020 08:10:51 +0000 (09:10 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Michael Haubenwallner <haubi@gentoo.org>
sys-devel/parity/Manifest [new file with mode: 0644]
sys-devel/parity/parity-2.0.0.ebuild [new file with mode: 0644]
sys-devel/parity/parity-9999.ebuild

diff --git a/sys-devel/parity/Manifest b/sys-devel/parity/Manifest
new file mode 100644 (file)
index 0000000..c740aca
--- /dev/null
@@ -0,0 +1 @@
+DIST parity-2.0.0.tar.bz2 371278 BLAKE2B 49a183c7249d83757b9596dad71ad4feb4fbcc63966cfc90da50cce5fb03aa4118360165640ad3ebe73e0a37da7efdd3583685fa084ba7bffa8f6c2c2168ef7c SHA512 ff0b166d400bc7e14ec3c46c2f7fa32a4dfd69f044d20ea97d7fc6361493f5def682dfc7b51e09619357d1e88c5b44e1105b785be3ed1f58c38eb3d35a9bc748
diff --git a/sys-devel/parity/parity-2.0.0.ebuild b/sys-devel/parity/parity-2.0.0.ebuild
new file mode 100644 (file)
index 0000000..24c5d76
--- /dev/null
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == 9999 ]]; then
+       inherit autotools git-r3
+       EGIT_REPO_URI="git@github.com:haubi/parity.git https://github.com/haubi/parity.git"
+       DEPEND="dev-util/confix"
+else
+       SRC_URI="https://github.com/mduft/${PN}/releases/download/${PV}/${P}.tar.bz2"
+       KEYWORDS="~x64-cygwin"
+fi
+DESCRIPTION="A POSIX to native Win32 Cross-Compiler Tool (requires Visual Studio)"
+HOMEPAGE="https://github.com/mduft/parity"
+
+parity-vcarchs() { echo x64=x86_64 x86=i686 ; }
+parity-vcvers-legacy() { echo 8_0 9_0 ; }
+parity-vcvers-current() { echo 10_0 11_0 12_0 14_0 15 16 ; }
+parity-vcvers() {
+       parity-vcvers-legacy
+       parity-vcvers-current
+}
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="$(
+       for a in $(parity-vcarchs); do echo "+vc${a%=*}"; done
+       for v in $(parity-vcvers-legacy); do echo "vc${v}"; done
+       for v in $(parity-vcvers-current); do echo "+vc${v}"; done
+)"
+
+if [[ ${PV} == 9999 ]]; then
+       src_prepare() {
+               default
+               confix --output || die
+               eautoreconf
+       }
+fi
+
+parity-enabled-vcarchs() {
+       local enabled= a
+       for a in $(parity-vcarchs) ; do
+               if use vc${a%=*} ; then
+                       enabled+=",${a#*=}"
+               fi
+       done
+       echo ${enabled#,}
+}
+
+parity-enabled-vcvers() {
+       local enabled= v
+       for v in $(parity-vcvers) ; do
+               if use vc${v} ; then
+                       enabled+=",${v/_/.}"
+               fi
+       done
+       echo ${enabled#,}
+}
+
+src_configure() {
+       local myconf=(
+               --enable-msvc-archs="$(parity-enabled-vcarchs)"
+               --enable-msvc-versions="$(parity-enabled-vcvers)"
+               --disable-default-msvc-version
+       )
+       econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+       if [[ -n ${ROOT%/} ]] ; then
+               einfo "To enable all available MSVC versions, on the target machine please run:"
+               einfo " '${EPREFIX}/usr/bin/parity-setup' --enable-all"
+       else
+               "${EPREFIX}"/usr/bin/parity-setup --enable-all
+       fi
+}
index 696e51ba12427f5edb52d3accd0f30219a1ba851..24c5d7682b3becd4256bfcce1f07198575f15241 100644 (file)
@@ -8,7 +8,7 @@ if [[ ${PV} == 9999 ]]; then
        EGIT_REPO_URI="git@github.com:haubi/parity.git https://github.com/haubi/parity.git"
        DEPEND="dev-util/confix"
 else
-       SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+       SRC_URI="https://github.com/mduft/${PN}/releases/download/${PV}/${P}.tar.bz2"
        KEYWORDS="~x64-cygwin"
 fi
 DESCRIPTION="A POSIX to native Win32 Cross-Compiler Tool (requires Visual Studio)"