net-print/cups-filters: Bump to version 1.22.1
authorLars Wendler <polynomial-c@gentoo.org>
Sun, 17 Feb 2019 14:15:19 +0000 (15:15 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Sun, 17 Feb 2019 14:15:36 +0000 (15:15 +0100)
Package-Manager: Portage-2.3.60, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-print/cups-filters/Manifest
net-print/cups-filters/cups-filters-1.22.1.ebuild [new file with mode: 0644]

index 33533122bf87793c96184407387c34c1ca5355b0..feb45a627db03c7674329f84681611362f66c389 100644 (file)
@@ -1,3 +1,4 @@
 DIST cups-filters-1.20.4.tar.xz 1474700 BLAKE2B 70948565e4a2b35d0c3bc510e7c03d77ac1ed47ab16a22bc9f60a7293fe5b5b08fdb1e95dd7a32f4c99a18676e50c48a515a954d437283ce7011ab616804e235 SHA512 4001cefbee945c326e3c597869763286e8665dee098b9aff76340dd249ef3e615f2a8df5c8e802e388b91dfd06ba9e8313b27908ca89ca120f899060785a6f07
 DIST cups-filters-1.21.6.tar.xz 1474944 BLAKE2B a4c3418accb9d2bf46a366ec6004919d2a5c2c0a02022102270da17fb81915428275aadf58f1f50f8ca022e1c09cbdbd7300492fa38c53d4a2cbc4c4b86a09e3 SHA512 804250745ac710706ff1bfa6e161c0b1a8a65a74850a76a311b7614694a7e5d07f01dfd15f277ad79ed7fe1e84ea680bab1643e0b82cefa3e26603fa2eea935a
 DIST cups-filters-1.22.0.tar.xz 1474616 BLAKE2B 045f403bcbae11bd6e0b523d741d1494e6328dfc9386393f974ff82ba816972688613e5c68739dcbf7733aa19c9c063be777cb017dbd041d9c2f23bd21c9182c SHA512 6129c948db2499a300c44ce88a287d5296af4771fb42e991121aaf4eb1258e17f1092afcbb90e5dd63572db410169fed65c6217d1ecd0ba834018acb4ef39bfa
+DIST cups-filters-1.22.1.tar.xz 1475456 BLAKE2B f5008cbcfc51f6a194dd5c50b3db288b2703b053d0f0e4ce525ccca255624efe43ec308b59310b24df5ab4f9f5afff54bfab5a102614a8d62209353245d66ed7 SHA512 5ed2f9fe6baecda8e5ed7c6c153e31ba3bc65a28608851141ae77dee5ddc31b3feaf22ab4798c1b47edb98af9f4cacd8437b880d693f5380febd24ef12c92b24
diff --git a/net-print/cups-filters/cups-filters-1.22.1.ebuild b/net-print/cups-filters/cups-filters-1.22.1.ebuild
new file mode 100644 (file)
index 0000000..8709d00
--- /dev/null
@@ -0,0 +1,137 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit perl-module systemd flag-o-matic
+
+if [[ "${PV}" == "9999" ]] ; then
+       inherit bzr autotools
+       EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+else
+       SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
+fi
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic ipp_autosetup jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+
+RDEPEND="
+       >=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils]
+       >=app-text/qpdf-8.3.0:=
+       dev-libs/glib:2
+       media-libs/fontconfig
+       media-libs/freetype:2
+       media-libs/lcms:2
+       >=net-print/cups-1.7.3
+       !<=net-print/cups-1.5.9999
+       sys-devel/bc
+       sys-libs/zlib
+       dbus? ( sys-apps/dbus )
+       foomatic? ( !net-print/foomatic-filters )
+       jpeg? ( virtual/jpeg:0 )
+       ldap? ( net-nds/openldap )
+       pclm? ( >=app-text/qpdf-8.1.0:= )
+       pdf? ( app-text/mupdf )
+       perl? ( dev-lang/perl:= )
+       png? ( media-libs/libpng:0= )
+       postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
+       tiff? ( media-libs/tiff:0 )
+       zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}
+       dev-util/gdbus-codegen
+       test? ( media-fonts/dejavu )
+"
+
+src_prepare() {
+       default
+       [[ "${PV}" == "9999" ]] && eautoreconf
+
+       # Bug #626800
+       append-cxxflags -std=c++11
+}
+
+src_configure() {
+       local myeconfargs=(
+               --docdir="${EPREFIX}/usr/share/doc/${PF}"
+               --enable-imagefilters
+               --localstatedir="${EPREFIX}"/var
+               --with-browseremoteprotocols=DNSSD,CUPS
+               --with-cups-rundir="${EPREFIX}"/run/cups
+               --with-fontdir="fonts/conf.avail"
+               --with-pdftops=pdftops
+               --with-rcdir=no
+               --without-php
+               $(use_enable dbus)
+               $(use_enable foomatic)
+               $(use_enable ipp_autosetup auto-setup-driverless)
+               $(use_enable ldap)
+               $(use_enable pclm)
+               $(use_enable pdf mutool)
+               $(use_enable postscript ghostscript)
+               $(use_enable postscript ijs)
+               $(use_enable static-libs static)
+               $(use_enable zeroconf avahi)
+               $(use_with jpeg)
+               $(use_with png)
+               $(use_with tiff)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_configure
+               perl-module_src_compile
+               popd > /dev/null
+       fi
+}
+
+src_install() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_install
+               perl_delete_localpod
+               popd > /dev/null
+       fi
+
+       if use postscript; then
+               # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+               dosym gstoraster /usr/libexec/cups/filter/pstoraster
+               dosym gstopxl /usr/libexec/cups/filter/pstopxl
+       fi
+
+       find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+       cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die
+
+       if ! use zeroconf ; then
+               sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+               sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+       fi
+
+       doinitd "${T}"/cups-browsed
+       systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+src_test() {
+       emake check
+}
+
+pkg_postinst() {
+       if ! use foomatic ; then
+               ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+               ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+       fi
+}