net-libs/libtirpc: Bump to version 1.0.3
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 20 Mar 2018 12:21:23 +0000 (13:21 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 20 Mar 2018 13:36:41 +0000 (14:36 +0100)
Package-Manager: Portage-2.3.24, Repoman-2.3.6

net-libs/libtirpc/Manifest
net-libs/libtirpc/libtirpc-1.0.3.ebuild [new file with mode: 0644]

index 26ffdc80d3342b0324ae81390022581fdd7a6e7b..5133ab31777505eeb8306665ba00e599faa30ec1 100644 (file)
@@ -1,3 +1,4 @@
 DIST libtirpc-1.0.1.tar.bz2 495125 BLAKE2B bb282c6d0aa097840758b00b37c73f391aabc234b5a6e51282004c2c46b403e2ca66180b77810ec6009ea9c9a2a6aae7907a15102ff42f51e3e57e151124bf4c SHA512 c9b449e737bc2bd3d56e31e8352f312e89a7ec2a11b73b5ac314e7d82d3b644c611e422b623912453b67b668f86a6de7bb7f18c9495dd15de8e2798ec2ff41c8
 DIST libtirpc-1.0.2.tar.bz2 509601 BLAKE2B 7ccf23ca200e2027a66a3105d9b3d0612ac66a08498931f66526a291be6ddef8e7df533af4d44a0e4a1178edd6d51ae39ca50c2536b9b1be7179e7f17cfd165e SHA512 6c819019a8e81d8263d3c509b2eee59ba1ef092222c5a0a8d28f004c711afa252097eca7e6b0b919b2d780883dfd9ee7a363df4cee7fd2c9159a065257637cec
+DIST libtirpc-1.0.3.tar.bz2 509831 BLAKE2B 3f908471b3e10f88329793db2c832754b9bb838d115235d7c25256da883960de8d8c94a6941fc9c2a3cc4dca9a77c32b5cb85bb347cc182e5a6255636b79b06e SHA512 1f1cf7dd6f30ddddc919e4caf6db926f1d532f78d5a93e8aaa2acde6b046be0650c4c46549da0ffd5fa7fb9e550af1a871ed6e02ededf504c6667d2e82eba2cc
 DIST libtirpc-glibc-nfs.tar.xz 8948 BLAKE2B 7316623d9f2b6928e296137fe2bf6794b208d549c2ffba9e4a35b47f7b04bf023798a09f38c02d039debf6adc466d7689cf3c8274d71a22eaff08729642c0a28 SHA512 90255bf0a27af16164e0710dd940778609925d473f4343093ff19d98cc4f23023788bf4edf0178eae1961afc0ba8b69b273de95b7d7e2afdb706701d8ba6f7ba
diff --git a/net-libs/libtirpc/libtirpc-1.0.3.ebuild b/net-libs/libtirpc/libtirpc-1.0.3.ebuild
new file mode 100644 (file)
index 0000000..68d0e2e
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal toolchain-funcs
+
+DESCRIPTION="Transport Independent RPC library (SunRPC replacement)"
+HOMEPAGE="http://libtirpc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
+       mirror://gentoo/${PN}-glibc-nfs.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/3" # subslot matches SONAME major
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="ipv6 kerberos static-libs"
+
+RDEPEND="kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+       app-arch/xz-utils
+       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-1.0.2-bcopy-to-memmove.patch"
+)
+
+src_prepare() {
+       cp -r "${WORKDIR}"/tirpc "${S}"/ || die
+       default
+       eapply_user
+       eautoreconf
+}
+
+multilib_src_configure() {
+       local myeconfargs=(
+               $(use_enable ipv6)
+               $(use_enable kerberos gssapi)
+               $(use_enable static-libs static)
+       )
+       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install() {
+       default
+
+       # libtirpc replaces rpc support in glibc, so we need it in /
+       gen_usr_ldscript -a tirpc
+}
+
+multilib_src_install_all() {
+       einstalldocs
+
+       insinto /etc
+       doins doc/netconfig
+
+       insinto /usr/include/tirpc
+       doins -r "${WORKDIR}"/tirpc/*
+
+       # makes sure that the linking order for nfs-utils is proper, as
+       # libtool would inject a libgssglue dependency in the list.
+       if ! use static-libs ; then
+               find "${ED}" -name "*.la" -delete || die
+       fi
+}