dev-erlang/yconf: Initial commit.
authorHanno <hanno@gentoo.org>
Wed, 2 Oct 2019 14:53:50 +0000 (16:53 +0200)
committerHanno <hanno@gentoo.org>
Wed, 2 Oct 2019 14:53:50 +0000 (16:53 +0200)
Dependency of new ejabberd.
Ebuild from vampik's overlay.

Signed-off-by: Hanno Boeck <hanno@gentoo.org>
Package-Manager: Portage-2.3.76, Repoman-2.3.17

dev-erlang/yconf/Manifest [new file with mode: 0644]
dev-erlang/yconf/metadata.xml [new file with mode: 0644]
dev-erlang/yconf/yconf-1.0.1.ebuild [new file with mode: 0644]

diff --git a/dev-erlang/yconf/Manifest b/dev-erlang/yconf/Manifest
new file mode 100644 (file)
index 0000000..63b6506
--- /dev/null
@@ -0,0 +1 @@
+DIST yconf-1.0.1.tar.gz 221704 BLAKE2B eec5ad6467af253c62523ebe431a7e117b5e76d1a0273792c5af4ac522ab10b3796910f11591a16e056ff368877c047d0ad9e47f63096a86de7a5d3ee9636ddf SHA512 c0b1a6e9534ee7d78963bd19df3f89622a719e2b5cc9c6299f4d39f08b5c8b8923f8697d57bd315e6cc0b41863adef2a8141f9d4e7d58bb0ade57c86f2835c1e
diff --git a/dev-erlang/yconf/metadata.xml b/dev-erlang/yconf/metadata.xml
new file mode 100644 (file)
index 0000000..aaa5b90
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>hanno@gentoo.org</email>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">processone/yconf</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-erlang/yconf/yconf-1.0.1.ebuild b/dev-erlang/yconf/yconf-1.0.1.ebuild
new file mode 100644 (file)
index 0000000..e4efd25
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="YAML configuration processor"
+HOMEPAGE="https://github.com/processone/yconf"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+       -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/erlang-17.1
+       >=dev-erlang/fast_yaml-1.0.20"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md )