net-dialup/accel-ppp: version bump to 1.10.2
authorSergey Popov <pinkbyte@gentoo.org>
Thu, 5 May 2016 15:11:37 +0000 (18:11 +0300)
committerSergey Popov <pinkbyte@gentoo.org>
Thu, 5 May 2016 15:16:02 +0000 (18:16 +0300)
Properly install ipoe kernel module,
add necessary LDFLAGS to properly handle lazy linking.
Drop old version.

Reported-by: Christian Roessner <info@roessner-net.com>
Gentoo-Bug: 549918

Package-Manager: portage-2.2.28

net-dialup/accel-ppp/Manifest
net-dialup/accel-ppp/accel-ppp-1.10.2.ebuild [moved from net-dialup/accel-ppp/accel-ppp-1.10.1.ebuild with 83% similarity]

index 697888a33f90dcb0b6074fbc61dbad2032234992..fe9feea82ea48055250566eccaf319e608a1195c 100644 (file)
@@ -1 +1,2 @@
 DIST accel-ppp-1.10.1.tar.bz2 1587117 SHA256 2333897563925d719b1b5e6fd05238fe769b967a9bac73d3b1daa1b8ff274b7d SHA512 43dc01992a8298970911d202736af0dcd3b46744d18ecce5d4987bab8d312cfb75d5a72a6f5c1b91ad7943c2c66371063402688cce57106db116b407205f142b WHIRLPOOL 0ce66a3a0daf6f4902baf7bf8ace545c1a2e8e9105bb62dc7dad96d3da131a215da17d6e722488fc9388acfb4a7f028bf9904e62c8c7a43fa7d2cb3aa9a7ca81
+DIST accel-ppp-1.10.2.tar.bz2 1587850 SHA256 ffd339ff1589c8b9e306028844e7156ee6d2b019b1219f1b8b62314c835e8a7d SHA512 6cc1d5f0786196fbbebc0f04830f780c1f2d2995bc7fb6384729b64820c74d0fb53f052bdaa71fa3b6165ab13cd7c137bfdc3ef717f6e866a329b893d7375ce1 WHIRLPOOL 050a5fe5eafba1e90f7b200a476e2edfbb878039a8e4ac5d06fdc195ad72720d7382267b7181e2a8ec47c2db8da4664b1315dff75ffcbc087c0e7e035577862c
similarity index 83%
rename from net-dialup/accel-ppp/accel-ppp-1.10.1.ebuild
rename to net-dialup/accel-ppp/accel-ppp-1.10.2.ebuild
index 4ea714a5a734f0025833e7b16eab6aa0a56eaa28..e711ab22c87b9cba7507a514f9846f420e4ae733 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=6
 
-inherit cmake-utils linux-info linux-mod
+inherit cmake-utils flag-o-matic linux-info linux-mod
 
 DESCRIPTION="High performance PPTP, PPPoE and L2TP server"
 HOMEPAGE="http://accel-ppp.sourceforge.net/"
@@ -42,8 +42,12 @@ src_prepare() {
        sed -i  -e "/mkdir/d" \
                -e "/echo/d" \
                -e "s: RENAME accel-ppp.conf.dist::" accel-pppd/CMakeLists.txt || die 'sed on accel-pppd/CMakeLists.txt failed'
+       sed -i -e '/modules_install/d' drivers/ipoe/CMakeLists.txt || die 'sed on drivers/ipoe/CMakeLists.txt failed'
 
-       eapply_user
+       # Bug #549918
+       append-ldflags -Wl,-z,lazy
+
+       cmake-utils_src_prepare
 }
 
 src_configure() {
@@ -69,6 +73,11 @@ src_compile() {
 }
 
 src_install() {
+       if use ipoe; then
+               local MODULE_NAMES="ipoe(accel-ppp:${BUILD_DIR}/drivers/ipoe/driver)"
+               linux-mod_src_install
+       fi
+
        cmake-utils_src_install
 
        use doc && dodoc -r rfc