dev-python/setuptools_trial: Revision bump, adds python 3.7, 3.8
authorBrian Dolbec <dolsen@gentoo.org>
Wed, 29 Apr 2020 00:21:13 +0000 (17:21 -0700)
committerBrian Dolbec <dolsen@gentoo.org>
Sat, 9 May 2020 00:50:51 +0000 (17:50 -0700)
Bump eapi, also duplicate the pkg tests inside our build environment.
metadata.xml take maintainership

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
dev-python/setuptools_trial/metadata.xml
dev-python/setuptools_trial/setuptools_trial-0.6.0-r1.ebuild [new file with mode: 0644]
dev-python/setuptools_trial/setuptools_trial-0.6.0.ebuild [deleted file]

index 2d9727db0f662a298a68396ea04d0e08bfbd3511..492255f2cfc11970a35d7a7a4298cebf1d0e26d4 100644 (file)
@@ -1,7 +1,10 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>dolsen@gentoo.org</email>
+               <name>Brian Dolbec</name>
+       </maintainer>
        <upstream>
                <maintainer>
                        <email>vladimir@rutsky.org</email>
diff --git a/dev-python/setuptools_trial/setuptools_trial-0.6.0-r1.ebuild b/dev-python/setuptools_trial/setuptools_trial-0.6.0-r1.ebuild
new file mode 100644 (file)
index 0000000..4bc6f90
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+inherit distutils-r1
+
+DESCRIPTION="Setuptools plugin that makes unit tests execute with trial instead of pyunit"
+HOMEPAGE="https://github.com/rutsky/setuptools-trial https://pypi.org/project/setuptools_trial/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="${RDEPEND}"
+
+python_test() {
+       distutils_install_for_testing
+
+       # The pkg test suite creates a virtualenv to install to for testing
+       # The distutils-r1 eclass already does the equivalent for us.
+       # So just run the same commands they do directly...
+       pushd "${S}"/tests/dummy_project > /dev/null || die
+       "${EPYTHON}" -m setup.py trial || \
+                       die "trial tests failed with ${EPYTHON}"
+       "${EPYTHON}" -m setup.py trial --reporter=text || \
+                       die "trial --reporter tests failed with ${EPYTHON}"
+       popd > /dev/null || die
+       pushd "${S}"/tests/alias_project > /dev/null || die
+       "${EPYTHON}" -m setup.py test || \
+                       die "alias_project tests failed with ${EPYTHON}"
+       popd > /dev/null || die
+}
diff --git a/dev-python/setuptools_trial/setuptools_trial-0.6.0.ebuild b/dev-python/setuptools_trial/setuptools_trial-0.6.0.ebuild
deleted file mode 100644 (file)
index f8e7fe2..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Setuptools plugin that makes unit tests execute with trial instead of pyunit"
-HOMEPAGE="https://github.com/rutsky/setuptools-trial https://pypi.org/project/setuptools_trial/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
-"
-
-DEPEND="
-       ${RDEPEND}
-"