net-dns/avahi: Add references to upstreamed patches
authorPacho Ramos <pacho@gentoo.org>
Sat, 17 Oct 2015 09:39:00 +0000 (11:39 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 17 Oct 2015 09:39:00 +0000 (11:39 +0200)
Package-Manager: portage-2.2.23

net-dns/avahi/avahi-0.6.32_rc.ebuild

index 6a9d2a6aa7905ad57778d2e45e733f5c8984580a..f3b222a7565a26efa62599073aa42d75369093e8 100644 (file)
@@ -99,18 +99,23 @@ src_prepare() {
                doxygen_to_devhelp.xsl || die
 
        # Make gtk utils optional
+       # https://github.com/lathiat/avahi/issues/24
        epatch "${FILESDIR}"/${PN}-0.6.30-optional-gtk-utils.patch
 
        # Fix init scripts for >=openrc-0.9.0, bug #383641
+       # https://github.com/lathiat/avahi/issues/25
        epatch "${FILESDIR}"/${PN}-0.6.x-openrc-0.9.x-init-scripts-fixes.patch
 
        # Don't install avahi-discover unless ENABLE_GTK_UTILS, bug #359575
+       # https://github.com/lathiat/avahi/issues/24
        epatch "${FILESDIR}"/${PN}-0.6.31-fix-install-avahi-discover.patch
 
-       # allow building client without the daemon
+       # Allow building client without the daemon
+       # https://github.com/lathiat/avahi/issues/26
        epatch "${FILESDIR}"/${PN}-0.6.31-build-client-without-daemon.patch
 
        # Fix build under various locales, bug #501664
+       # https://github.com/lathiat/avahi/issues/27
        epatch "${FILESDIR}"/${PN}-0.6.31-fix-locale-build.patch
 
        # Bug #525832
@@ -199,10 +204,12 @@ multilib_src_install() {
        use bookmarks && use python && use dbus && use gtk || \
                rm -f "${ED}"/usr/bin/avahi-bookmarks
 
+       # https://github.com/lathiat/avahi/issues/28
        use howl-compat && dosym avahi-compat-howl.pc /usr/$(get_libdir)/pkgconfig/howl.pc
        use mdnsresponder-compat && dosym avahi-compat-libdns_sd/dns_sd.h /usr/include/dns_sd.h
 
        # Needed for running on systemd properly, bug #537000
+       # https://github.com/lathiat/avahi/issues/29
        if multilib_is_native_abi; then
                ln -s avahi-daemon.service "${D}$(systemd_get_unitdir)"/dbus-org.freedesktop.Avahi.service || die
        fi