Version bump (#145624). Remove obsolete versions.
authorAlin Năstac <mrness@gentoo.org>
Sat, 20 Jan 2007 09:30:37 +0000 (09:30 +0000)
committerAlin Năstac <mrness@gentoo.org>
Sat, 20 Jan 2007 09:30:37 +0000 (09:30 +0000)
Package-Manager: portage-2.1.1-r2

app-text/gocr/ChangeLog
app-text/gocr/files/digest-gocr-0.43 [new file with mode: 0644]
app-text/gocr/files/gocr-0.43-makefile.patch [new file with mode: 0644]
app-text/gocr/gocr-0.43.ebuild [new file with mode: 0644]

index 29f9b54df94587d3875ca5f66a07307f02450778..d1588d5accef2396645decc3faf987760c05e500 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for app-text/gocr
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/ChangeLog,v 1.35 2006/06/06 15:59:04 blubb Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/ChangeLog,v 1.36 2007/01/20 09:30:37 mrness Exp $
+
+*gocr-0.43 (20 Jan 2007)
+
+  20 Jan 2007; Alin Nastac <mrness@gentoo.org>
+  +files/gocr-0.43-makefile.patch, -gocr-0.39.ebuild, -gocr-0.40.ebuild,
+  +gocr-0.43.ebuild:
+  Version bump (#145624). Remove obsolete versions.
 
   06 Jun 2006; Simon Stelling <blubb@gentoo.org> gocr-0.40-r2.ebuild:
   stable on amd64
diff --git a/app-text/gocr/files/digest-gocr-0.43 b/app-text/gocr/files/digest-gocr-0.43
new file mode 100644 (file)
index 0000000..69c75eb
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 f989fe8e24f82d19c8ce55df15784e15 gocr-0.43.tar.gz 820923
+RMD160 ee914cf5d0a14274d15b17c0c21b90a73f422283 gocr-0.43.tar.gz 820923
+SHA256 36e88624511dd8f366fa679beaf14afa7d11e71c2dd6947a43eab31c8bc27fe9 gocr-0.43.tar.gz 820923
diff --git a/app-text/gocr/files/gocr-0.43-makefile.patch b/app-text/gocr/files/gocr-0.43-makefile.patch
new file mode 100644 (file)
index 0000000..946f1ff
--- /dev/null
@@ -0,0 +1,32 @@
+diff -Nru gocr-0.43.orig/frontend/Makefile gocr-0.43/frontend/Makefile
+--- gocr-0.43.orig/frontend/Makefile   2007-01-20 11:07:44.000000000 +0200
++++ gocr-0.43/frontend/Makefile        2007-01-20 11:07:20.000000000 +0200
+@@ -11,5 +11,5 @@
+ gnome/Makefile: gnome/configure
+-      (cd gnome;configure)
++      (cd gnome;./configure)
+diff -Nru gocr-0.43.orig/src/Makefile.in gocr-0.43/src/Makefile.in
+--- gocr-0.43.orig/src/Makefile.in     2006-10-31 13:20:09.000000000 +0200
++++ gocr-0.43/src/Makefile.in  2007-01-20 11:10:46.000000000 +0200
+@@ -43,7 +43,8 @@
+ CPPFLAGS=@CPPFLAGS@
+ # to see the config.h
+ CFLAGS=@CFLAGS@ $(CPPFLAGS) -I../include $(DEFS)
+-LDFLAGS=@LDFLAGS@ @LIBS@ -L.
++LDFLAGS=@LDFLAGS@
++LIBADD=@LIBS@
+ DESTDIR=@prefix@
+ .c.o: $(INCLUDEFILES)
+@@ -54,7 +55,7 @@
+ all: $(PROGRAM) $(LIBPGMASCLIB)
+ $(PROGRAM): $(LIBPGMASCLIB) gocr.o
+-      $(CC) -o $@ gocr.o $(LDFLAGS) ./lib$(PGMASCLIB).a
++      $(CC) $(LDFLAGS) gocr.o ./lib$(PGMASCLIB).a $(LIBADD) -o $@
+       if test -r $(PROGRAM); then cp $@ ../bin; fi
+ gocr.o: gocr.h Makefile
diff --git a/app-text/gocr/gocr-0.43.ebuild b/app-text/gocr/gocr-0.43.ebuild
new file mode 100644 (file)
index 0000000..0381839
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.43.ebuild,v 1.1 2007/01/20 09:30:37 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="An OCR (Optical Character Recognition) reader"
+HOMEPAGE="http://jocr.sourceforge.net"
+SRC_URI="mirror://sourceforge/jocr/${P}.tar.gz"
+LICENSE="GPL-2"
+
+IUSE="gtk doc"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=media-libs/netpbm-9.12
+       doc? ( >=media-gfx/transfig-3.2 )
+       gtk? ( =x11-libs/gtk+-1*
+              media-gfx/imagemagick )
+       tk? ( dev-lang/tk )"
+
+DOCS="AUTHORS BUGS CREDITS HISTORY RE* TODO"
+
+src_unpack() {
+
+       unpack ${A}
+
+       epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+
+       local mymakes="src man"
+
+       use gtk && mymakes="${mymakes} frontend"
+       use doc && mymakes="${mymakes} doc examples"
+
+       econf || die "econf failed"
+       make ${mymakes} || die "make ${mymakes} failed"
+
+}
+
+src_install() {
+
+       make DESTDIR="${D}" prefix="/usr"  exec_prefix="/usr" install || die "make install failed"
+       # remove the tk frontend if tk is not selected
+       use tk || rm "${D}"/usr/bin/gocr.tcl
+       # install the gtk frontend
+       use gtk && dobin "${S}"/frontend/gnome/src/gtk-ocr
+       # and install the documentation and examples
+       if use doc ; then
+               DOCS="${DOCS} doc/gocr.html doc/examples.txt doc/unicode.txt"
+               insinto /usr/share/doc/${P}/examples
+               doins "${S}"/examples/*.{fig,tex,pcx}
+       fi
+       # and then install all the docs 
+       dodoc ${DOCS}
+
+}