app-arch/pixz: use default src_{compile,install} targets
authorMike Frysinger <vapier@gentoo.org>
Thu, 16 Feb 2017 23:11:41 +0000 (18:11 -0500)
committerMike Frysinger <vapier@gentoo.org>
Thu, 16 Feb 2017 23:44:48 +0000 (18:44 -0500)
This is a standard autotools package, so use the default compile/install
steps from the PM.  These ad-hoc funcs look like leftovers from the much
older versions.

app-arch/pixz/pixz-1.0.6.ebuild
app-arch/pixz/pixz-9999.ebuild

index 7e31c748a8b9a291ed92e0e229f1b11f1f9c3697..7caca229a63e8d4f7da1980c9805cdd0c3fbbbf9 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=6
 
-inherit toolchain-funcs flag-o-matic autotools
+inherit flag-o-matic autotools
 
 DESCRIPTION="Parallel Indexed XZ compressor"
 HOMEPAGE="https://github.com/vasi/pixz"
@@ -41,13 +41,3 @@ src_configure() {
        export ac_cv_file_src_pixz_1=$([[ -f src/pixz.1 ]] && echo yes || echo no)
        econf
 }
-
-src_compile() {
-       emake CC="$(tc-getCC)" OPT=""
-}
-
-src_install() {
-       dobin src/pixz
-       doman src/pixz.1
-       dodoc NEWS README.md TODO
-}
index 7e31c748a8b9a291ed92e0e229f1b11f1f9c3697..7caca229a63e8d4f7da1980c9805cdd0c3fbbbf9 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=6
 
-inherit toolchain-funcs flag-o-matic autotools
+inherit flag-o-matic autotools
 
 DESCRIPTION="Parallel Indexed XZ compressor"
 HOMEPAGE="https://github.com/vasi/pixz"
@@ -41,13 +41,3 @@ src_configure() {
        export ac_cv_file_src_pixz_1=$([[ -f src/pixz.1 ]] && echo yes || echo no)
        econf
 }
-
-src_compile() {
-       emake CC="$(tc-getCC)" OPT=""
-}
-
-src_install() {
-       dobin src/pixz
-       doman src/pixz.1
-       dodoc NEWS README.md TODO
-}