dev-php/pecl-radius: add PHP 7.3 support
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 7 Jun 2019 13:16:59 +0000 (15:16 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 7 Jun 2019 14:08:05 +0000 (16:08 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-php/pecl-radius/pecl-radius-1.4.0_beta1-r2.ebuild

index 318f7f3641bfc50d0928d65fd842a139d61cbb0f..12aaad4b9dd333777d757fbe862f9454be2dcdaa 100644 (file)
@@ -1,13 +1,13 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI="7"
 
 PHP_EXT_NAME="radius"
 PHP_EXT_INI="yes"
 PHP_EXT_ZENDEXT="no"
 
-USE_PHP="php5-6 php7-0 php7-1 php7-2"
+USE_PHP="php5-6 php7-1 php7-2 php7-3"
 PHP_EXT_PECL_FILENAME="${PN/pecl-/}-${PV/_beta/b}.tgz"
 PHP_EXT_S="${WORKDIR}/${PHP_EXT_PECL_FILENAME%.tgz}"
 
@@ -24,7 +24,7 @@ S="${PHP_EXT_S}"
 
 RDEPEND="
        php_targets_php5-6? ( dev-lang/php:5.6[pcntl,sockets] )
-       php_targets_php7-0? ( dev-lang/php:7.0[pcntl,sockets] )
        php_targets_php7-1? ( dev-lang/php:7.1[pcntl,sockets] )
        php_targets_php7-2? ( dev-lang/php:7.2[pcntl,sockets] )
+       php_targets_php7-3? ( dev-lang/php:7.3[pcntl,sockets] )
 "