dev-python/jsonschema: Revision bump, make functools32 dependency conditional on...
authorPatrick McLean <chutzpah@gentoo.org>
Wed, 9 Sep 2015 01:17:58 +0000 (18:17 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 9 Sep 2015 01:17:58 +0000 (18:17 -0700)
Package-Manager: portage-2.2.20.1

dev-python/jsonschema/jsonschema-2.5.1-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/jsonschema/jsonschema-2.5.1-r1.ebuild b/dev-python/jsonschema/jsonschema-2.5.1-r1.ebuild
new file mode 100644 (file)
index 0000000..7109010
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="https://pypi.python.org/pypi/jsonschema http://github.com/Julian/jsonschema"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc ~ppc64 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+       dev-python/rfc3986[${PYTHON_USEDEP}]
+       dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+       dev-python/webcolors[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep dev-python/functools32[$(python_gen_usedep 'python2*' pypy)] 'python2*' pypy)
+       "
+DEPEND="${RDEPEND}
+       dev-python/vcversioner[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+       "${PYTHON}" -m unittest discover || die "Testing failed with ${EPYTHON}"
+}