dev-python/sphinxcontrib-github-alt: new package.
authorMarius Brehler <marbre@linux.sungazer.de>
Mon, 20 Nov 2017 08:29:11 +0000 (09:29 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Thu, 30 Nov 2017 14:46:15 +0000 (15:46 +0100)
Link to GitHub issues, pull requests, commits and users for a particular
project.

Required to build the docs for jupyter_core.

It's called 'alt' because sphinxcontrib-github already exists. IPython &
Jupyter projects have been using the syntax defined in this extension for some
time before this made it into its own package.

Closes: https://bugs.gentoo.org/637990
Closes: https://bugs.gentoo.org/638200
Closes: https://github.com/gentoo/gentoo/pull/6246
Package-Manager: Portage-2.3.13, Repoman-2.3.3

dev-python/sphinxcontrib-github-alt/Manifest [new file with mode: 0644]
dev-python/sphinxcontrib-github-alt/files/sphinxcontrib-github-alt-1.0-init.py.patch [new file with mode: 0644]
dev-python/sphinxcontrib-github-alt/files/sphinxcontrib-github-alt-1.0-setup.py.patch [new file with mode: 0644]
dev-python/sphinxcontrib-github-alt/metadata.xml [new file with mode: 0644]
dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.0.ebuild [new file with mode: 0644]

diff --git a/dev-python/sphinxcontrib-github-alt/Manifest b/dev-python/sphinxcontrib-github-alt/Manifest
new file mode 100644 (file)
index 0000000..5743847
--- /dev/null
@@ -0,0 +1 @@
+DIST sphinxcontrib-github-alt-1.0.tar.gz 3213 SHA256 721efe70ec7ab9be12a929af01242147e1d4a05921103d38c0bc207db3b70aae SHA512 57f5ab3a5d679634ce0c2ea8c78069f37ed5a5d3c32fe6cf61851ed4a9e8b6b9b6c882f486eb84914153b4121dacc25fd4b11edee111630001ae9bc324f2250e WHIRLPOOL a0e470f10a51e4f592dd441a58d13c5f1ada87e09840e44c768240863615128a4ac9e9ec700a3553145fefb28faddedecf61522194dbe823cfea762b02da1ff5
diff --git a/dev-python/sphinxcontrib-github-alt/files/sphinxcontrib-github-alt-1.0-init.py.patch b/dev-python/sphinxcontrib-github-alt/files/sphinxcontrib-github-alt-1.0-init.py.patch
new file mode 100644 (file)
index 0000000..e4274fd
--- /dev/null
@@ -0,0 +1,8 @@
+__init__.py for sphinxcontrib_github_alt by Marius Brehler.
+
+Patch by Marius Brehler <marbrbre@linux.sungazer.de>.
+--- /dev/null
++++ b/sphinxcontrib_github_alt/__init__.py
+@@ -0,0 +1 @@
++from .sphinxcontrib_github_alt import *
+\ No newline at end of file
diff --git a/dev-python/sphinxcontrib-github-alt/files/sphinxcontrib-github-alt-1.0-setup.py.patch b/dev-python/sphinxcontrib-github-alt/files/sphinxcontrib-github-alt-1.0-setup.py.patch
new file mode 100644 (file)
index 0000000..2bc518c
--- /dev/null
@@ -0,0 +1,19 @@
+setup.py for sphinxcontrib_github_alt by Marius Brehler <marbre@linux.sungazer.de>.
+
+Patch by Marius Brehler <marbrbre@linux.sungazer.de>.
+--- /dev/null
++++ b/setup.py
+@@ -0,0 +1,12 @@
++from distutils.core import setup
++
++setup(name='sphinxcontrib_github_alt',
++      version='1.0',
++      author='Jupyter Development Team',
++      author_email='jupyter@googlegroups.com',
++      url='https://github.com/jupyter/sphinxcontrib_github_alt',
++      packages=['sphinxcontrib_github_alt'],
++      classifiers=[
++          'License :: OSI Approved :: BSD License'
++      ]
++)
+\ No newline at end of file
diff --git a/dev-python/sphinxcontrib-github-alt/metadata.xml b/dev-python/sphinxcontrib-github-alt/metadata.xml
new file mode 100644 (file)
index 0000000..33f8e97
--- /dev/null
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>marbre@linux.sungazer.de</email>
+               <name>Marius Brehler</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Gentoo Proxy Maintainers Project</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>sci@gentoo.org</email>
+               <name>Gentoo Science Project</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">jupyter/sphinxcontrib_github_alt</remote-id>
+               <remote-id type="pypi">sphinxcontrib_github_alt</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.0.ebuild b/dev-python/sphinxcontrib-github-alt/sphinxcontrib-github-alt-1.0.ebuild
new file mode 100644 (file)
index 0000000..f34c1f9
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6}  )
+
+inherit distutils-r1
+
+MY_PN="sphinxcontrib_github_alt"
+
+DESCRIPTION="Link to GitHub issues, pull requests, commits and users from Sphinx docs"
+HOMEPAGE="https://github.com/jupyter/sphinxcontrib_github_alt"
+SRC_URI="https://github.com/jupyter/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+       dev-python/sphinx[${PYTHON_USEDEP}]
+       dev-python/docutils[${PYTHON_USEDEP}]"
+
+PATCHES=(
+       "${FILESDIR}/${P}"-setup.py.patch
+       "${FILESDIR}/${P}"-init.py.patch
+)
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+       distutils-r1_python_prepare_all
+
+       mv "${WORKDIR}/${MY_PN}-${PV}"/sphinxcontrib_github_alt.py "${WORKDIR}/${MY_PN}-${PV}/${MY_PN}/" || die
+}