dev-libs/darts: Use EAPI="7".
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Fri, 9 Aug 2019 16:11:22 +0000 (16:11 +0000)
committerMike Gilbert <floppym@gentoo.org>
Fri, 9 Aug 2019 18:38:58 +0000 (14:38 -0400)
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-libs/darts/darts-0.32.ebuild

index 115570f6f76cb8ca6442cc5d9a1dc1b1b55bd5b7..68be2668b01f723942e5c832de58907aa0734fcd 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 2003-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI="7"
 
 DESCRIPTION="A C++ template library that implements Double-Array"
 HOMEPAGE="http://chasen.org/~taku/software/darts/"
@@ -11,16 +11,25 @@ LICENSE="|| ( BSD LGPL-2.1 )"
 SLOT="0"
 KEYWORDS="amd64 ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
 IUSE="zlib"
+
+BDEPEND=""
 DEPEND="zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+       econf $(use_with zlib)
+}
 
 src_compile() {
-       econf `use_with zlib` || die
-       emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" || die
+       emake CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
 }
 
 src_install() {
-       emake DESTDIR="${D}" install || die
+       default
 
-       dodoc AUTHORS ChangeLog NEWS README || die
-       dohtml doc/* || die
+       dodoc AUTHORS ChangeLog
+       (
+               docinto html
+               dodoc doc/*
+       )
 }