projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7beb346
)
dev-python/py2neo: Remove Py2
author
David Seifert
<soap@gentoo.org>
Sat, 28 Dec 2019 16:14:12 +0000
(17:14 +0100)
committer
David Seifert
<soap@gentoo.org>
Sat, 28 Dec 2019 16:14:12 +0000
(17:14 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/py2neo/py2neo-3.1.2.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/py2neo/py2neo-3.1.2.ebuild
b/dev-python/py2neo/py2neo-3.1.2.ebuild
index 6d1fc20736fe878d460b0aef0a2c7356ee95c128..865ae1c8b842b9c4e10c87ef9c04c303b84981d1 100644
(file)
--- a/
dev-python/py2neo/py2neo-3.1.2.ebuild
+++ b/
dev-python/py2neo/py2neo-3.1.2.ebuild
@@
-3,7
+3,7
@@
EAPI=6
-PYTHON_COMPAT=( python
{2_7,3_5,3_6} pypy{,3}
)
+PYTHON_COMPAT=( python
3_{5,6} pypy3
)
inherit distutils-r1
@@
-17,9
+17,3
@@
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_compile() {
- # https://github.com/nigelsmall/py2neo/issues/380
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}