dev-ruby/parallel: cleanup
authorHans de Graaff <graaff@gentoo.org>
Sat, 9 Nov 2019 06:22:39 +0000 (07:22 +0100)
committerHans de Graaff <graaff@gentoo.org>
Sat, 9 Nov 2019 06:22:39 +0000 (07:22 +0100)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/parallel/Manifest
dev-ruby/parallel/parallel-1.16.2.ebuild [deleted file]

index dd9056b5a370bff23787521714efd869e2614537..716be3846c0f80f6b8af9d97818e731ad55b7d1a 100644 (file)
@@ -1,3 +1,2 @@
-DIST parallel-1.16.2.tar.gz 20853 BLAKE2B 4d30dd43f854ca9c3a6b739a36f250374a527d00c12e1221e5cb5a9da06fda66b0fadaaf7b9b5f5ac69549e9b1c75eb8f1c17a4bcd160ba15086013884176c07 SHA512 0d3cd59527ab1ff9da995f71cf2c04d6eec5276d5dcbab8b62844e18c3cf83de9b288c0f184d26dcf2897539bba2a6ac58fd0efb02952cc7999f411c3efb5b33
 DIST parallel-1.17.0.tar.gz 20882 BLAKE2B a8afb329de1d8d0d577c1b53d990c4f1cd8ec9f23b8cc1005310903954f180c52535e3d8a5901862f1504da0981f3e16cf73a848403ed49872aa3dc45781b888 SHA512 92c7f4475a791da4feb0afda3686a4f9e9cc397ac278560c177552abf586054594d29a67b583845b69433e7824c0ce36bcffe98e13051242db0e5ee4a3c7a17c
 DIST parallel-1.18.0.tar.gz 21095 BLAKE2B d47286c719810699cd5098b9d28e4e00cec2a7a27141a2dd932023f9fdeaac389f2be9aa8196820ad3d28d26c141f41565ad363fdca9bbca75e18a8d9d7fa4b5 SHA512 2869a8b82da2b1f2595be04616afa5bce62eac3833d743304dc4371db63be7645437c009c202d4690fe5dc221766e2a0f25790335d7a25b355c3f3b8034f8319
diff --git a/dev-ruby/parallel/parallel-1.16.2.ebuild b/dev-ruby/parallel/parallel-1.16.2.ebuild
deleted file mode 100644 (file)
index 471513d..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRAINSTALL="Readme.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Run any code in parallel Processes or Threads"
-HOMEPAGE="https://github.com/grosser/parallel"
-LICENSE="MIT"
-SRC_URI="https://github.com/grosser/parallel/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-KEYWORDS="~amd64"
-SLOT="1"
-IUSE="test"
-
-DEPEND+="test? ( sys-process/lsof )"
-
-ruby_add_bdepend "
-       test? ( dev-ruby/ruby-progressbar dev-ruby/activerecord:5.2 dev-ruby/sqlite3 )"
-
-each_ruby_prepare() {
-       # Make sure the correct ruby is used for testing
-       sed -e 's:ruby :'${RUBY}' :' -i spec/parallel_spec.rb || die
-}
-
-all_ruby_prepare() {
-       sed -i -e '/bundler/ s:^:#:' \
-               -e '1i require "tempfile"; gem "activerecord", "~>5.2.0"' spec/cases/helper.rb || die
-       sed -i -e '3irequire "timeout"' spec/spec_helper.rb || die
-
-       # Avoid a failing spec regarding to pipes. The spec seems like it
-       # should always fail.
-       sed -e '/does not open unnecessary pipes/,/end/ s:^:#:' \
-               -i spec/parallel_spec.rb || die
-
-       # Avoid fragile ar sqlite tests. They throw ReadOnly errors every now and then.
-       sed -i -e '/works with SQLite in/,/end/ s:^:#:' spec/parallel_spec.rb || die
-
-       # Avoid spec broken on Ruby 2.1 that clearly doesn't match code and doesn't really test anything
-       sed -i -e '/doesnt use Etc.nprocessors in Ruby 2.1 and below/,/end/ s:^:#:' spec/parallel_spec.rb || die
-}
-
-each_ruby_test() {
-       # Set RUBYLIB explicitly for the ruby's that get started from the specs.
-       TRAVIS=true RUBYLIB="lib" ${RUBY} -S rspec-3 spec || die
-}