dev-python/jeepney-0.4.1: Version bump, add py38
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 4 Dec 2019 19:22:28 +0000 (11:22 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 4 Dec 2019 20:05:14 +0000 (12:05 -0800)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/jeepney/Manifest
dev-python/jeepney/jeepney-0.4.1.ebuild [new file with mode: 0644]

index dba5fd54f6bd6cf192468c848f3cb36712a6cc78..3959bb0f20bc6812354b9cd668388c426d440b51 100644 (file)
@@ -1 +1,2 @@
 DIST jeepney-0.3.1.tar.gz 22271 BLAKE2B a8de58e4ef4c4d1874c8995e3726a4bfa26a8db4a63040658c4edfd1742fa1c22de52d8cbee4913b1973279938544481fe2c2aef3138dc0ef724f7a99a39c617 SHA512 ad1a2d220a7626a3bdadf6fba6a591d1b498a9f6bb34607860213efddf49bbe67a4dc2d504decd906c560c519302f1fa45b85ba348156e8bec288f525d502e82
+DIST jeepney-0.4.1.tar.gz 27706 BLAKE2B 152bf872621a0e023b9f44bb165113b2c3ef0037f66cb1c2aa15423d68ae5c295ad100aba855f061840054a25c3ed30a2d1faed09cf2130235df72c70738c791 SHA512 46aed19fd29df724af0e78ec0acabeb196324444e682817c330f3fd290a52cf6a6cb639f8c76f4ef5311817c4e051d7231b4f26af3cb6768bdd8c4bec7589210
diff --git a/dev-python/jeepney/jeepney-0.4.1.ebuild b/dev-python/jeepney/jeepney-0.4.1.ebuild
new file mode 100644 (file)
index 0000000..48c7b3c
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Python 3.4 and older aren't supported
+PYTHON_COMPAT=( pypy3 python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, pure Python DBus protocol wrapper"
+HOMEPAGE="https://gitlab.com/takluyver/jeepney"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/testpath[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+       dev-python/sphinx_rtd_theme
+
+python_install_all() {
+       if use examples; then
+               docompress -x "/usr/share/doc/${PF}/examples"
+               dodoc -r examples
+       fi
+       distutils-r1_python_install_all
+}