media-tv/tvheadend: Update hdhomerun patch for 9999
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 20 Jan 2019 21:15:57 +0000 (21:15 +0000)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 20 Jan 2019 21:15:57 +0000 (21:15 +0000)
Closes: https://bugs.gentoo.org/675916
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
media-tv/tvheadend/files/tvheadend-4.3-hdhomerun.patch [new file with mode: 0644]
media-tv/tvheadend/tvheadend-9999.ebuild

diff --git a/media-tv/tvheadend/files/tvheadend-4.3-hdhomerun.patch b/media-tv/tvheadend/files/tvheadend-4.3-hdhomerun.patch
new file mode 100644 (file)
index 0000000..1689c2e
--- /dev/null
@@ -0,0 +1,36 @@
+diff -Naur a/configure b/configure
+--- a/configure        2019-01-20 21:12:12.634450200 +0000
++++ b/configure        2019-01-20 21:12:52.502298542 +0000
+@@ -411,7 +411,7 @@
+ else
+   if enabled_or_auto hdhomerun_client; then
+-    if check_cc_header 'libhdhomerun/hdhomerun' libhdhomerun; then
++    if check_cc_header 'hdhomerun/hdhomerun' libhdhomerun; then
+       enable  hdhomerun_client
+       LDFLAGS="$LDFLAGS -lhdhomerun"
+     fi
+diff -Naur a/src/input/mpegts/tvhdhomerun/tvhdhomerun.c b/src/input/mpegts/tvhdhomerun/tvhdhomerun.c
+--- a/src/input/mpegts/tvhdhomerun/tvhdhomerun.c       2019-01-20 21:12:12.707451725 +0000
++++ b/src/input/mpegts/tvhdhomerun/tvhdhomerun.c       2019-01-20 21:12:35.990947079 +0000
+@@ -17,7 +17,7 @@
+  *  along with this program.  If not, see <http://www.gnu.org/licenses/>.
+  */
+-#include "libhdhomerun/hdhomerun.h"
++#include <hdhomerun/hdhomerun.h>
+ #include "tvheadend.h"
+ #include "input.h"
+diff -Naur a/src/input/mpegts/tvhdhomerun/tvhdhomerun_frontend.c b/src/input/mpegts/tvhdhomerun/tvhdhomerun_frontend.c
+--- a/src/input/mpegts/tvhdhomerun/tvhdhomerun_frontend.c      2019-01-20 21:12:12.707451725 +0000
++++ b/src/input/mpegts/tvhdhomerun/tvhdhomerun_frontend.c      2019-01-20 21:12:35.991947101 +0000
+@@ -17,7 +17,7 @@
+  *  along with this program.  If not, see <http://www.gnu.org/licenses/>.
+  */
+-#include "libhdhomerun/hdhomerun.h"
++#include <hdhomerun/hdhomerun.h>
+ #include <fcntl.h>
+ #include "tvheadend.h"
index 700a7cc5a1d599ec528cc91b0efba3871935a14f..7fa2c9c7f2551a25b3eb218a13940c4e106b01ca 100644 (file)
@@ -57,7 +57,7 @@ REQUIRED_USE="
 
 PATCHES=(
        "${FILESDIR}"/${PN}-4.0.9-use_system_queue.patch
-       "${FILESDIR}"/${PN}-4.2.1-hdhomerun.patch
+       "${FILESDIR}"/${PN}-4.3-hdhomerun.patch
        "${FILESDIR}"/${PN}-4.2.2-dtv_scan_tables.patch
 )