acct-user/smtpd: add for opensmtpd
authorJason A. Donenfeld <zx2c4@gentoo.org>
Wed, 5 Feb 2020 12:20:47 +0000 (13:20 +0100)
committerJason A. Donenfeld <zx2c4@gentoo.org>
Wed, 5 Feb 2020 12:29:28 +0000 (13:29 +0100)
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
acct-user/smtpd/metadata.xml [new file with mode: 0644]
acct-user/smtpd/smtpd-0.ebuild [new file with mode: 0644]

diff --git a/acct-user/smtpd/metadata.xml b/acct-user/smtpd/metadata.xml
new file mode 100644 (file)
index 0000000..915f002
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>zx2c4@gentoo.org</email>
+               <name>Jason A. Donenfeld</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/acct-user/smtpd/smtpd-0.ebuild b/acct-user/smtpd/smtpd-0.ebuild
new file mode 100644 (file)
index 0000000..1a15db0
--- /dev/null
@@ -0,0 +1,13 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="daemon user for smtpd"
+ACCT_USER_ID=25
+ACCT_USER_GROUPS=( smtpd )
+ACCT_USER_HOME=/var/empty
+
+acct-user_add_deps