Initial import. Also closes bug #98335
authorJohn Mylchreest <johnm@gentoo.org>
Fri, 17 Feb 2006 19:27:34 +0000 (19:27 +0000)
committerJohn Mylchreest <johnm@gentoo.org>
Fri, 17 Feb 2006 19:27:34 +0000 (19:27 +0000)
Package-Manager: portage-2.1_pre4-r1

media-sound/monopod/ChangeLog [new file with mode: 0644]
media-sound/monopod/metadata.xml [new file with mode: 0644]
media-sound/monopod/monopod-0.3.ebuild [new file with mode: 0644]

diff --git a/media-sound/monopod/ChangeLog b/media-sound/monopod/ChangeLog
new file mode 100644 (file)
index 0000000..ffe1f7c
--- /dev/null
@@ -0,0 +1,10 @@
+# ChangeLog for media-sound/monopod
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/monopod/ChangeLog,v 1.1 2006/02/17 19:27:34 johnm Exp $
+
+*monopod-0.3 (17 Feb 2006)
+
+  17 Feb 2006; John Mylchreest <johnm@gentoo.org> +metadata.xml,
+  +monopod-0.3.ebuild:
+  initial import. Also closes bug #98335.
+
diff --git a/media-sound/monopod/metadata.xml b/media-sound/monopod/metadata.xml
new file mode 100644 (file)
index 0000000..dbd65e1
--- /dev/null
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>sound</herd>
+       <maintainer>
+               <email>johnm@gentoo.org</email>
+               <name>John Mylchreest</name>
+       </maintainer>
+       <longdescription lang="en">
+               Monopod is a very simplistic Podcast client with planned iPod support
+               written in GTK#. It's to the point, without the bloat.
+       </longdescription>
+</pkgmetadata>
+
diff --git a/media-sound/monopod/monopod-0.3.ebuild b/media-sound/monopod/monopod-0.3.ebuild
new file mode 100644 (file)
index 0000000..6597b40
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/monopod/monopod-0.3.ebuild,v 1.1 2006/02/17 19:27:34 johnm Exp $
+
+inherit gnome2 mono
+
+DESCRIPTION="A very lightweight podcast client in GTK#"
+HOMEPAGE="http://downloads.usefulinc.com/monopod/"
+SRC_URI="http://downloads.usefulinc.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND=">=dev-lang/mono-1.1.6
+               >=dev-dotnet/glade-sharp-1.9.5
+               >=dev-dotnet/gconf-sharp-2.0
+               >=dev-dotnet/gtk-sharp-1.9.5
+               >=dev-dotnet/gnome-sharp-1.9.5
+               dev-db/sqlite"
+
+USE_DESTDIR=1
+DOCS="ChangeLog NEWS README TODO AUTHORS"
+
+src_compile() {
+       gnome2_src_configure
+       emake -j1 || "make failed"
+}
+
+src_install() {
+       gnome2_src_install
+}