dev-python/nose-exclude: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Wed, 16 Sep 2015 07:53:07 +0000 (09:53 +0200)
committerJustin Lecher <jlec@gentoo.org>
Wed, 16 Sep 2015 08:53:42 +0000 (10:53 +0200)
Fix HOMEPAGE
Enable test for python2

Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/nose-exclude/Manifest
dev-python/nose-exclude/nose-exclude-0.1.9.ebuild
dev-python/nose-exclude/nose-exclude-0.2.0.ebuild
dev-python/nose-exclude/nose-exclude-0.3.0.ebuild
dev-python/nose-exclude/nose-exclude-0.4.1.ebuild [new file with mode: 0644]

index 49f302dcfc9e0dff9d644bc1115821271f827bec..acdbe6a4760ef7687b712d55891fcde12142a2f1 100644 (file)
@@ -1,3 +1,4 @@
 DIST nose-exclude-0.1.9.tar.gz 3444 SHA256 c2862e55f9c6245141fc0437bad5f71a3aa8377d2727b85694884887027625ca SHA512 2f26a3d371bf50d71e235e801c0bef37ac3e7388df7bd16203b5bb330393b2c938deb4a0c2502c75c10038c798456174b74ef4dd10567ac103bf965fcfaf4dea WHIRLPOOL b926c273a1c16a69ab15157d87b079fecd813b579c69eaa9cceee441dca1607e2b949af991e3d0b23d593b07fd9597eedde1e8721fe38a897e0f6f7d221b817d
 DIST nose-exclude-0.2.0.tar.gz 5741 SHA256 27babdc53e0741ed09d21b7fdb5d244aabb1679f67ef81289f0f34e50aca51c9 SHA512 0c23fe809e7e4f75e34bd6e7922cbc021ca880511f9f4d6094ec7cb330261ce2eb10135595f64d555c6503eef5280f8fc41665d8a491e1a01a566c5e277c83f4 WHIRLPOOL 34d9731097e5a6f8e0de111438b3d5db65ec470a79317336c3eb2fceb583a4b7929d4c9b0da8d6b1fc8e8132d2724f2263c2b70e5fc9530dd38be554994b05e8
 DIST nose-exclude-0.3.0.tar.gz 5789 SHA256 eb40022d531c21e827e1261f3a51665a1535b83023598df1e968f41a7d9b3b88 SHA512 25a87e2fe8f424bd009b02b854029dc371ed9a73c7a062c5da32dc76949f0f19c47ac6ab844f2143651e7b66a6b52300edd0eeab3346292671c311ef42f5565c WHIRLPOOL a0841effaf08bda27678d7dffc19c1e933d83fa0ce7340745e72dba17faebc35b85323e598c3d089bcfca70ec521f6cd61c5d46cc56be2f60bf8e24b5904c09e
+DIST nose-exclude-0.4.1.tar.gz 5930 SHA256 44466a9bcb56d2e568750f91504d1278c74eabb259a305b06e975b87b51635da SHA512 07dd869f948fb6e6f23dbecc316d08f23701f30ace3755e560f94deeb62cb2b5e1f5690477260d8d3a7f634e3e9959142a340f4fe0886e2ad12852444244ca3f WHIRLPOOL 5ef409e2ada229f7e7fc4c32ea86377709d305fa3a1f11543ba7d6aeee67558eeb554cdce06a9a67b7d9ae80d66ce90ca9a5608e4d54610eed8a9a02ea20e7da
index 63c84a7d49897793bffffaccd7b7fbdff6cc810c..143d257aa28506ca376e46fd5d06a9cfdd9413a0 100644 (file)
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
 inherit distutils-r1
 
 DESCRIPTION="Exclude specific directories from nosetests runs"
-HOMEPAGE="https://bitbucket.org/kgrandis/nose-exclude"
+HOMEPAGE="https://github.com/kgrandis/nose-exclude"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="LGPL-2.1"
index 3185a051be496d2f38e512a26afb41045e5eeb00..b20ca544503e523c4364fff2b88e3319c457e9d2 100644 (file)
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
 inherit distutils-r1
 
 DESCRIPTION="Exclude specific directories from nosetests runs"
-HOMEPAGE="https://bitbucket.org/kgrandis/nose-exclude"
+HOMEPAGE="https://github.com/kgrandis/nose-exclude"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="LGPL-2.1"
@@ -20,6 +20,6 @@ RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
 RESTRICT="test"
 
 python_test() {
-       # https://bitbucket.org/kgrandis/nose-exclude/issue/10/test-failures-with-python-3
+       # https://github.com/kgrandis/nose-exclude/issue/10/test-failures-with-python-3
        esetup.py test
 }
index c3a90062bd4f0e3e3973e6942160a07e863babfa..09afe293eb6963d08842c46dcb7a7ee195de7e35 100644 (file)
@@ -3,12 +3,13 @@
 # $Id$
 
 EAPI=5
+
 PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
 
 inherit distutils-r1
 
 DESCRIPTION="Exclude specific directories from nosetests runs"
-HOMEPAGE="https://bitbucket.org/kgrandis/nose-exclude"
+HOMEPAGE="https://github.com/kgrandis/nose-exclude"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="LGPL-2.1"
@@ -17,9 +18,9 @@ KEYWORDS="~amd64 ~x86"
 
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
-RESTRICT="test"
 
 python_test() {
-       # https://bitbucket.org/kgrandis/nose-exclude/issue/10/test-failures-with-python-3
+       # https://github.com/kgrandis/nose-exclude/issue/10/test-failures-with-python-3
+       python_is_python3 && return
        esetup.py test
 }
diff --git a/dev-python/nose-exclude/nose-exclude-0.4.1.ebuild b/dev-python/nose-exclude/nose-exclude-0.4.1.ebuild
new file mode 100644 (file)
index 0000000..09afe29
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Exclude specific directories from nosetests runs"
+HOMEPAGE="https://github.com/kgrandis/nose-exclude"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+
+python_test() {
+       # https://github.com/kgrandis/nose-exclude/issue/10/test-failures-with-python-3
+       python_is_python3 && return
+       esetup.py test
+}