dev-python/pyhamcrest: Bump to 2.0.2
authorMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 12:24:46 +0000 (14:24 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 12:26:27 +0000 (14:26 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyhamcrest/Manifest
dev-python/pyhamcrest/pyhamcrest-2.0.2.ebuild [new file with mode: 0644]

index 33812a1949e57d7ed7a5bfdc2d37d3e55b57c448..935a77e4c4af8c7b8fac94af222af53628cfe474 100644 (file)
@@ -1,2 +1,3 @@
 DIST PyHamcrest-1.10.1.gh.tar.gz 59019 BLAKE2B 1a090533ea8fe2dff9ad232b2e6dbf82841c38f3699e57750e2309b06a46e70ae5a9c7d087baf06de53e17323a5e36edee1a01d7a4442374d15b76a7723c2031 SHA512 f7e79f7d26c4c6add042052e451898bbf5adf21b05a234cc62bce890d68f5997693b042a9daf136f7026040a8ab7bf28b829288417b947973dcb959bf613a37b
 DIST PyHamcrest-1.9.0.gh.tar.gz 57650 BLAKE2B c497688f03ec3b072d8ab076fc096a442d5cbbd94493eae57779879ccb6f281477aeeb7f7a67e539442010e60194f9f04a6deddd1d2267e9743742b45433f124 SHA512 3a878637ed5138365416c170871a63640f089047b723c7ec8db893dd716c0b1cdad16a98584700405693b954af7d4868a8543d1a3fc58ded22b493c8c61661b4
+DIST PyHamcrest-2.0.2.gh.tar.gz 55491 BLAKE2B 749f227b8cb1180a64e24cdbf97b6f610b9871b21215a761642d19fdd43ad8e175718b12cfb0de2cdb5c6ae8c3c5271e04b7c3b489e01ac689769e24202ece56 SHA512 d6e510ca1e6533b425b424d411e23c4ee2a6bad2d635695e4e68f991fbdc57269c3a433361e431cb5dda7891278951d5de7a05f5c1c167714eecdaf74644d1c8
diff --git a/dev-python/pyhamcrest/pyhamcrest-2.0.2.ebuild b/dev-python/pyhamcrest/pyhamcrest-2.0.2.ebuild
new file mode 100644 (file)
index 0000000..ec73612
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+MY_PN="PyHamcrest"
+
+DESCRIPTION="Hamcrest framework for matcher objects"
+HOMEPAGE="https://github.com/hamcrest/PyHamcrest"
+SRC_URI="https://github.com/hamcrest/PyHamcrest/archive/V${PV}.tar.gz -> ${MY_PN}-${PV}.gh.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+distutils_enable_sphinx doc \
+       dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_install_all() {
+       use examples && dodoc -r examples
+       distutils-r1_python_install_all
+}