media-libs/opus: bump version to 1.3.1
authorStefan Strogin <steils@gentoo.org>
Wed, 8 May 2019 01:21:57 +0000 (04:21 +0300)
committerStefan Strogin <steils@gentoo.org>
Wed, 8 May 2019 01:30:39 +0000 (04:30 +0300)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Stefan Strogin <steils@gentoo.org>
media-libs/opus/Manifest
media-libs/opus/opus-1.3.1.ebuild [new file with mode: 0644]

index 069cd06939da2f924349d31121aebdf943abc6a2..b573688fde25e783cc7c4caf4ad5054f9e8ab056 100644 (file)
@@ -1 +1,2 @@
+DIST opus-1.3.1.tar.gz 1040054 BLAKE2B e0aab38518938157a6ef27307f52d9d3f9c12a2fef4c7e5b4168c2f6fc04d79e333ebe477059b3e6a0518fcf6aa089b5eb1c8de68d83474e237c0f73e5a221cb SHA512 6cd5e4d8a0551ed5fb59488c07a5cc18a241d1fde5f9eb9f16cd4e77abcdb4134dd51ad1d737be1e6039bfa56912510b8648152f2478a1f21c7c1d9ce32933cd
 DIST opus-1.3.tar.gz 1032750 BLAKE2B 7c79cecb957b0353e35758989b07502f2d4531869985639a069dec8737c15061b56ebff5babe31ad316afa9f7787bde6a7c544fa5be10c1e02ccfdff1a80d5c7 SHA512 438635667e72c326d6d06a30e0b3a5564ba6cf5d484066456e1118e1c2fe3a61b959d0afa77a1084b177b72f9230618b6b55c78bc4e24e9127a09fd345b42518
diff --git a/media-libs/opus/opus-1.3.1.ebuild b/media-libs/opus/opus-1.3.1.ebuild
new file mode 100644 (file)
index 0000000..e2eef3f
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Open codec for interactive speech and music transmission over the Internet"
+HOMEPAGE="https://opus-codec.org/"
+SRC_URI="https://archive.mozilla.org/pub/opus/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+INTRINSIC_FLAGS="cpu_flags_x86_sse cpu_flags_arm_neon"
+IUSE="custom-modes doc static-libs ${INTRINSIC_FLAGS}"
+
+DEPEND="doc? (
+               app-doc/doxygen
+               media-gfx/graphviz
+       )"
+
+multilib_src_configure() {
+       local myeconfargs=(
+               $(use_enable custom-modes)
+               $(use_enable doc)
+               $(use_enable static-libs static)
+       )
+       for i in ${INTRINSIC_FLAGS} ; do
+               use ${i} && myeconfargs+=( --enable-intrinsics )
+       done
+       ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+       default
+       find "${ED}" -name "*.la" -delete || die
+}