dev-ml/ocamlnet: Replace STRIP_MASK with RESTRICT=strip
authorMichał Górny <mgorny@gentoo.org>
Sun, 14 Apr 2019 08:06:44 +0000 (10:06 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 5 Jul 2019 20:16:59 +0000 (22:16 +0200)
Closes: https://bugs.gentoo.org/651440
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-ml/ocamlnet/ocamlnet-4.1.2.ebuild
dev-ml/ocamlnet/ocamlnet-4.1.3.ebuild
dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild

index 6d89e100f0ec91ac6a26b207a6750c378a7dfb9e..a16de2e6b12f05d543ff9f75e2adfddf8d61d00f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -14,7 +14,7 @@ LICENSE="ZLIB GPL-2+"
 SLOT="0/${PV}"
 KEYWORDS="amd64 ppc x86 x86-fbsd"
 IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
-RESTRICT="installsources"
+RESTRICT="installsources strip"
 
 # the auth-dh compile flag has been disabled as well, since it depends on
 # ocaml-cryptgps, which is not available.
@@ -74,8 +74,3 @@ src_compile() {
                emake -j1 opt
        fi
 }
-
-src_install() {
-       export STRIP_MASK="*/bin/*"
-       findlib_src_install
-}
index 1460d03f5cc44a3c7cb82fbb64c7a8a6cc5555f4..d6e4d239beb681e5a3a0107c537753fda017625d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -14,7 +14,7 @@ LICENSE="ZLIB GPL-2+"
 SLOT="0/${PV}"
 KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
 IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
-RESTRICT="installsources"
+RESTRICT="installsources strip"
 
 # the auth-dh compile flag has been disabled as well, since it depends on
 # ocaml-cryptgps, which is not available.
@@ -70,8 +70,3 @@ src_compile() {
                emake -j1 opt
        fi
 }
-
-src_install() {
-       export STRIP_MASK="*/bin/*"
-       findlib_src_install
-}
index 1460d03f5cc44a3c7cb82fbb64c7a8a6cc5555f4..d6e4d239beb681e5a3a0107c537753fda017625d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -14,7 +14,7 @@ LICENSE="ZLIB GPL-2+"
 SLOT="0/${PV}"
 KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
 IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
-RESTRICT="installsources"
+RESTRICT="installsources strip"
 
 # the auth-dh compile flag has been disabled as well, since it depends on
 # ocaml-cryptgps, which is not available.
@@ -70,8 +70,3 @@ src_compile() {
                emake -j1 opt
        fi
 }
-
-src_install() {
-       export STRIP_MASK="*/bin/*"
-       findlib_src_install
-}