dev-python/liblarch: bump to 3.0 for py3, fix HOMEPAGE, add tests
authorMart Raudsepp <leio@gentoo.org>
Sat, 16 May 2020 05:01:50 +0000 (08:01 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sat, 16 May 2020 05:02:36 +0000 (08:02 +0300)
This is in preparation of upcoming gtg-0.4 release (and being able
to work a bit on that upstream on a gentoo machine easier)

Bug: https://bugs.gentoo.org/707912
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
dev-python/liblarch/Manifest
dev-python/liblarch/liblarch-3.0.ebuild [new file with mode: 0644]

index 4343da1f0cdc26cbb10d408dc6b3998751368212..b19b83b19013b12dccbb5e6a48174f2db7277a58 100644 (file)
@@ -1 +1,2 @@
 DIST liblarch-2.1.0.tar.gz 26829 BLAKE2B 14bf85bb91d800e5ca0d8eb4da6c2d9b3979b4560280776c276cad9cbd026331768729e5b4ca9b4646c6b199566cfb5a42b5148ef089e0ae5ec7e45d09090ba5 SHA512 fd6a6c48142e434f49fb49d9dee874b88f013775c280dd2dc929ed5fff4df7bd3743bf915b09dac4329f894cac24e466d78366a072136de389725bc5ed985ec1
+DIST liblarch-3.0.tar.gz 55785 BLAKE2B 1d69882b8748e7b3a1b0af6ef66f5a32e04e3b742d10ba3971fc5c0f490ca692584d46a849cc2e6d3654ab577f7698619540b54f9a13a7b0d5079b34fee248f7 SHA512 bf50880402ae8b490c5d98b158c5123d00340d981b26a5dec4538f1f4a1008efd5cfe024251728f90f1ebaade4ee18601fa30432d64921c3986b53efc531c68a
diff --git a/dev-python/liblarch/liblarch-3.0.ebuild b/dev-python/liblarch/liblarch-3.0.ebuild
new file mode 100644 (file)
index 0000000..e0cb347
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library to handle directed acyclic graphs"
+HOMEPAGE="https://wiki.gnome.org/Projects/liblarch"
+SRC_URI="https://github.com/getting-things-gnome/liblarch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+       dev-python/pygobject:3[${PYTHON_USEDEP}]
+       x11-libs/gtk+:3[introspection]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+       test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+       virtx nosetests -v || die "Tests fail with ${EPYTHON}"
+}