dev-qt/qtgui: Fix build with -xcb and -no-libinput
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 12 Nov 2019 17:13:48 +0000 (18:13 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 20 Nov 2019 21:20:42 +0000 (22:20 +0100)
Thanks-to: Petr Zima <zima@matfyz.cz>
Thanks-to: Jimi Huotari <chiitoo@gentoo.org>
Closes: https://bugs.gentoo.org/699110
Package-Manager: Portage-2.3.79, Repoman-2.3.17
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-qt/qtgui/files/qtgui-5.13.2-no-xcb-no-xkbcommon.patch [new file with mode: 0644]
dev-qt/qtgui/qtgui-5.13.2.ebuild

diff --git a/dev-qt/qtgui/files/qtgui-5.13.2-no-xcb-no-xkbcommon.patch b/dev-qt/qtgui/files/qtgui-5.13.2-no-xcb-no-xkbcommon.patch
new file mode 100644 (file)
index 0000000..6f63a63
--- /dev/null
@@ -0,0 +1,34 @@
+From 2749833d844b20a9e642b2df2074dfafde8622d3 Mon Sep 17 00:00:00 2001
+From: Jimi Huotari <chiitoo@gentoo.org>
+Date: Wed, 6 Nov 2019 00:54:57 +0200
+Subject: [PATCH] Fix build with -xcb and -no-libinput
+
+Since a34e81ab [1], 'xkbcommon_support' is under
+'src/platformsupport/input', and will not be defined when building
+with -no-libinput, and as such, 'xkbcommon_support-private' added in
+'src/plugins/platforms/xcb/xcb_qpa_lib.pro' will be unknown.
+
+1. https://code.qt.io/cgit/qt/qtbase.git/commit/?h=5.14&id=a34e81ab
+
+Change-Id: I79563b329623651b462b8fedcfb59ef5f2c2e52a
+Gentoo-bug: https://bugs.gentoo.org/699110
+Suggested-by: Petr Zima <zima@matfyz.cz>
+---
+ src/platformsupport/platformsupport.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/platformsupport/platformsupport.pro b/src/platformsupport/platformsupport.pro
+index 6d4f1b93bd1..877665ff06b 100644
+--- a/src/platformsupport/platformsupport.pro
++++ b/src/platformsupport/platformsupport.pro
+@@ -11,7 +11,7 @@ SUBDIRS = \
+ qtConfig(freetype)|darwin|win32: \
+     SUBDIRS += fontdatabases
+-qtConfig(evdev)|qtConfig(tslib)|qtConfig(libinput)|qtConfig(integrityhid) {
++qtConfig(evdev)|qtConfig(tslib)|qtConfig(libinput)|qtConfig(integrityhid)|qtConfig(xkbcommon) {
+     SUBDIRS += input
+     input.depends += devicediscovery
+ }
+-- 
+2.16.3
index 6bec13c736d101152501b23e727d2f5c0e798483..20a5adb6d94f7f51fc218f5fcecb50a71f046559 100644 (file)
@@ -124,7 +124,10 @@ QT5_GENTOO_PRIVATE_CONFIG=(
        :gui
 )
 
-PATCHES+=( "${FILESDIR}/qt-5.12-gcc-avx2.patch" ) # bug 672946
+PATCHES+=(
+       "${FILESDIR}/qt-5.12-gcc-avx2.patch" # bug 672946
+       "${FILESDIR}/${P}-no-xcb-no-xkbcommon.patch" # bug 699110
+)
 
 src_prepare() {
        # don't add -O3 to CXXFLAGS, bug 549140