dev-ros/pr2_description: fix building tests; they still fail though.
authorAlexis Ballier <aballier@gentoo.org>
Fri, 7 Jul 2017 18:10:57 +0000 (20:10 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 7 Jul 2017 18:10:57 +0000 (20:10 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.2

dev-ros/pr2_description/files/tests.patch [new file with mode: 0644]
dev-ros/pr2_description/pr2_description-1.12.0.ebuild
dev-ros/pr2_description/pr2_description-9999.ebuild

diff --git a/dev-ros/pr2_description/files/tests.patch b/dev-ros/pr2_description/files/tests.patch
new file mode 100644 (file)
index 0000000..40c3a37
--- /dev/null
@@ -0,0 +1,13 @@
+Index: pr2_common-1.12.0/pr2_description/test/test_urdf.cpp
+===================================================================
+--- pr2_common-1.12.0.orig/pr2_description/test/test_urdf.cpp
++++ pr2_common-1.12.0/pr2_description/test/test_urdf.cpp
+@@ -100,7 +100,7 @@ int walker( std::string & result, int& t
+         }
+         xml_file.close();
+-        boost::shared_ptr<urdf::ModelInterface> robot = urdf::parseURDF(xml_string);
++        std::shared_ptr<urdf::ModelInterface> robot = urdf::parseURDF(xml_string);
+         if (!robot) test_result = test_result || 1;
+       }
index 75466430c0599d36225106b8d6ee97ea7c604237..1a73af70cf05bb2db1057b8d16c1567e1f685c7d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -19,3 +19,4 @@ DEPEND="${RDEPEND}
        dev-ros/convex_decomposition
        dev-ros/ivcon
        test? ( dev-libs/urdfdom dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/tests.patch" )
index 75466430c0599d36225106b8d6ee97ea7c604237..1a73af70cf05bb2db1057b8d16c1567e1f685c7d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -19,3 +19,4 @@ DEPEND="${RDEPEND}
        dev-ros/convex_decomposition
        dev-ros/ivcon
        test? ( dev-libs/urdfdom dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/tests.patch" )