sys-cluster/kube-scheduler: repoman fixes and glep 81 migration
authorWilliam Hubbs <williamh@gentoo.org>
Sat, 25 Jan 2020 01:22:16 +0000 (19:22 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Sat, 25 Jan 2020 01:22:16 +0000 (19:22 -0600)
Signed-off-by: William Hubbs <williamh@gentoo.org>
sys-cluster/kube-scheduler/kube-scheduler-1.17.2.ebuild

index bb8891fc85e187325a815ffaceaeb9759a105bef..0faf33996b1a151fc81f681902013aa61d01956b 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-inherit go-module user
+inherit go-module
 
 DESCRIPTION="Kubernetes Scheduler"
 HOMEPAGE="https://github.com/kubernetes/kubernetes https://kubernetes.io"
@@ -12,17 +12,16 @@ LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="~amd64"
 
-DEPEND="dev-go/go-bindata
+COMMON_DEPEND="acct-group/kube-scheduler
+       acct-user/kube-scheduler"
+DEPEND="${COMMON_DEPEND}
+       dev-go/go-bindata
        >=dev-lang/go-1.13"
+       RDEPEND="${COMMON_DEPEND}"
 
 RESTRICT="test"
 S="${WORKDIR}/kubernetes-${PV}"
 
-pkg_setup() {
-       enewgroup ${PN}
-       enewuser ${PN} -1 -1 -1 ${PN}
-}
-
 src_prepare() {
        default
        sed -i -e "/vendor\/github.com\/jteeuwen\/go-bindata\/go-bindata/d" -e "s/-s -w/-w/" hack/lib/golang.sh || die