Add snapshot of alsa-driver building on 2.6.19 kernel.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 30 Nov 2006 20:36:32 +0000 (20:36 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 30 Nov 2006 20:36:32 +0000 (20:36 +0000)
Package-Manager: portage-2.1.2_rc2-r3

media-sound/alsa-driver/ChangeLog
media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild [new file with mode: 0644]
media-sound/alsa-driver/files/digest-alsa-driver-1.0.14_pre20061130 [new file with mode: 0644]
media-sound/alsa-headers/ChangeLog
media-sound/alsa-headers/alsa-headers-1.0.14_pre20061130.ebuild [new file with mode: 0644]
media-sound/alsa-headers/files/digest-alsa-headers-1.0.14_pre20061130 [new file with mode: 0644]

index 43cbeab71e8f92970b56c6e9732c26e3b175796a..bb57fd43eb958a5926f4ba26d8518599853580ca 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-sound/alsa-driver
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.237 2006/10/28 19:12:38 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.238 2006/11/30 20:33:53 flameeyes Exp $
+
+*alsa-driver-1.0.14_pre20061130 (30 Nov 2006)
+
+  30 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
+  +alsa-driver-1.0.14_pre20061130.ebuild:
+  Add snapshot of alsa-driver building on 2.6.19 kernel.
 
   28 Oct 2006; Ryan Hill <dirtyepic@gentoo.org> alsa-driver-1.0.13.ebuild:
   Forgot to stablize alsa-driver-1.0.13 w/ alsa-headers-1.0.13 on x86.
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild
new file mode 100644 (file)
index 0000000..8c28d2e
--- /dev/null
@@ -0,0 +1,186 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.14_pre20061130.ebuild,v 1.1 2006/11/30 20:33:53 flameeyes Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit linux-mod flag-o-matic eutils multilib autotools
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="oss doc debug"
+
+RDEPEND="virtual/modutils
+        ~media-sound/alsa-headers-${PV}
+        !media-sound/snd-aoa"
+DEPEND="${RDEPEND}
+       virtual/linux-sources
+       sparc? ( >=sys-devel/autoconf-2.50 )
+       sys-apps/debianutils"
+
+PROVIDE="virtual/alsa"
+
+pkg_setup() {
+       # By default, drivers for all supported cards will be compiled.
+       # If you want to only compile for specific card(s), set ALSA_CARDS
+       # environment to a space-separated list of drivers that you want to build.
+       # For example:
+       #
+       #       env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+       #
+       ALSA_CARDS=${ALSA_CARDS:-all}
+
+       # Which drivers need PNP
+       local PNP_DRIVERS="interwave interwave-stb"
+
+       CONFIG_CHECK="SOUND"
+       SND_ERROR="ALSA is already compiled into the kernel."
+       SOUND_ERROR="Your kernel doesn't have sound support enabled."
+       SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers.  Please disable them and re-emerge alsa-driver."
+       PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}).  Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
+
+       if [[ "${ALSA_CARDS}" == "all" ]]; then
+
+               # Ignore PNP checks for ppc architecture, as PNP can't be enabled there.
+               if [[ ${ARCH} != "ppc" ]]; then
+                       CONFIG_CHECK="${CONFIG_CHECK} PNP"
+               fi
+       else
+               for pnpdriver in ${PNP_DRIVERS}; do
+                       hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
+               done
+       fi
+
+       linux-mod_pkg_setup
+
+       if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
+               export CBUILD=${CBUILD-${CHOST}}
+               export CHOST="sparc64-unknown-linux-gnu"
+       fi
+}
+
+src_unpack() {
+       unpack ${A}
+
+       cd "${S}"
+
+       epatch "${FILESDIR}/${PN}-1.0.10_rc1-include.patch"
+
+       epatch "${FILESDIR}/${PN}-mcp55.patch"
+
+       if kernel_is ge 2 6 17 ; then
+               # These are needed for some drivers to build with kernel 2.6.17
+               # until a refreshed release of alsa-driver is done
+               epatch "${FILESDIR}/${PN}-1.0.11-kernel-2.6.17.patch"
+
+               # asihpi driver is broken, skip it until upstream releases something
+               # working.
+               sed -i -e 's:asihpi/::' "${S}/pci/Makefile"
+       fi
+
+       convert_to_m "${S}/Makefile"
+       sed -i -e 's:\(.*depmod\):#\1:' "${S}/Makefile"
+
+       emake -j1 all-deps || die "make all-deps failed"
+       eaclocal
+       eautoconf
+}
+
+src_compile() {
+       local myABI=${ABI:-${DEFAULT_ABI}}
+
+       # Should fix bug #46901
+       is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
+       append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
+
+       econf $(use_with oss) \
+               $(use_with debug debug full) \
+               --with-kernel="${KV_DIR}" \
+               --with-build="${KV_OUT_DIR}" \
+               --with-isapnp=yes \
+               --with-sequencer=yes \
+               --with-cards="${ALSA_CARDS}" || die "econf failed"
+
+       # linux-mod_src_compile doesn't work well with alsa
+
+       ARCH=$(tc-arch-kernel)
+       ABI=${KERNEL_ABI}
+       emake LDFLAGS="$(raw-ldflags)" HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
+       ARCH=$(tc-arch)
+       ABI=${myABI}
+
+       if use doc;
+       then
+               ebegin "Building Documentation"
+               cd ${S}/scripts
+               emake || die Failed making docs in ${S}/scripts
+
+               cd ${S}/doc/DocBook
+               emake || die Failed making docs in ${S}/doc/DocBook
+               eend $?
+       fi
+}
+
+
+src_install() {
+       emake DESTDIR=${D} install-modules || die "make install failed"
+
+       dodoc CARDS-STATUS FAQ README WARNING TODO
+
+       if use doc; then
+               docinto doc
+               dodoc doc/*
+               rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
+
+               docinto DocBook
+               dodoc doc/DocBook/*
+               rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
+
+               docinto Documentation
+               dodoc sound/Documentation/*
+       fi
+
+       if kernel_is 2 6; then
+               # mv the drivers somewhere they won't be killed by the kernel's make modules_install
+               mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
+               rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
+       fi
+}
+
+pkg_postinst() {
+       einfo
+       einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
+       einfo
+       einfo "Also, remember that all mixer channels will be MUTED by default."
+       einfo "Use the 'alsamixer' program to unmute them."
+       einfo
+       einfo "Version 1.0.3 and above should work with version 2.6 kernels."
+       einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
+       einfo
+
+       linux-mod_pkg_postinst
+
+       einfo "Check out the ALSA installation guide availible at the following URL:"
+       einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
+
+       if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
+               # Cleanup if they had older alsa installed
+               for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
+                       rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
+               done
+
+               for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
+                       rmdir ${dir} &> /dev/null
+               done
+       fi
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.14_pre20061130 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.14_pre20061130
new file mode 100644 (file)
index 0000000..1b2782e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 4242572cad1a76d467b457dcb7bcc89a alsa-driver-1.0.14_pre20061130.tar.bz2 7261863
+RMD160 026d3e288f91c9cea325394e1656b33a1da2bbe4 alsa-driver-1.0.14_pre20061130.tar.bz2 7261863
+SHA256 ba835bad2864f9d3d83e55c087aca336270b13bde87bad2b72e2636f1798bf1f alsa-driver-1.0.14_pre20061130.tar.bz2 7261863
index d2b5d8f0c9f1271a87c034b79763c421e9693d35..8fe9c5bded73beb657649be7a90d20120d48759a 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-sound/alsa-headers
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/ChangeLog,v 1.106 2006/11/08 01:32:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/ChangeLog,v 1.107 2006/11/30 20:36:32 flameeyes Exp $
+
+*alsa-headers-1.0.14_pre20061130 (30 Nov 2006)
+
+  30 Nov 2006; Diego Pettenò <flameeyes@gentoo.org>
+  +alsa-headers-1.0.14_pre20061130.ebuild:
+  Add snapshot of alsa-driver building on 2.6.19 kernel.
 
   08 Nov 2006; Jeroen Roovers <jer@gentoo.org> alsa-headers-1.0.13.ebuild:
   Stable for HPPA (bug #150540).
diff --git a/media-sound/alsa-headers/alsa-headers-1.0.14_pre20061130.ebuild b/media-sound/alsa-headers/alsa-headers-1.0.14_pre20061130.ebuild
new file mode 100644 (file)
index 0000000..e156faf
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/alsa-headers-1.0.14_pre20061130.ebuild,v 1.1 2006/11/30 20:36:32 flameeyes Exp $
+
+inherit eutils
+
+MY_PN=${PN/headers/driver}
+MY_P="${MY_PN}-${PV/_rc/rc}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Header files for Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+# Remove the sound symlink workaround...
+pkg_setup() {
+       if [[ -L "${ROOT}/usr/include/sound" ]]; then
+               rm      "${ROOT}/usr/include/sound"
+       fi
+}
+
+src_unpack() {
+       unpack ${A}
+
+       cd "${S}"
+       epatch "${FILESDIR}/${PN}-1.0.6a-user.patch"
+}
+
+src_compile() { :; }
+
+src_install() {
+       cd "${S}/alsa-kernel/include"
+       insinto /usr/include/sound
+       doins *.h || die "include failed"
+}
diff --git a/media-sound/alsa-headers/files/digest-alsa-headers-1.0.14_pre20061130 b/media-sound/alsa-headers/files/digest-alsa-headers-1.0.14_pre20061130
new file mode 100644 (file)
index 0000000..1b2782e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 4242572cad1a76d467b457dcb7bcc89a alsa-driver-1.0.14_pre20061130.tar.bz2 7261863
+RMD160 026d3e288f91c9cea325394e1656b33a1da2bbe4 alsa-driver-1.0.14_pre20061130.tar.bz2 7261863
+SHA256 ba835bad2864f9d3d83e55c087aca336270b13bde87bad2b72e2636f1798bf1f alsa-driver-1.0.14_pre20061130.tar.bz2 7261863