net-firewall/iptables: use -fpack-struct w/x32 ABI #472388
authorMike Frysinger <vapier@gentoo.org>
Thu, 20 Aug 2015 17:30:35 +0000 (13:30 -0400)
committerMike Frysinger <vapier@gentoo.org>
Thu, 20 Aug 2015 17:31:16 +0000 (13:31 -0400)
Apply a hack for the x32 ABI to try to get it working.  The current
version is entirely broken, so this is still better than the status quo.

net-firewall/iptables/iptables-1.4.21-r2.ebuild

index 268e0f7de373dcdfe53376e010c991e8030898a7..e87e4ed137c21955868155deeb6d75bddc290c8b 100644 (file)
@@ -7,7 +7,7 @@ EAPI="5"
 # Force users doing their own patches to install their own tools
 AUTOTOOLS_AUTO_DEPEND=no
 
-inherit eutils multilib systemd toolchain-funcs autotools
+inherit eutils multilib systemd toolchain-funcs autotools flag-o-matic
 
 DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
 HOMEPAGE="http://www.netfilter.org/projects/iptables/"
@@ -44,6 +44,9 @@ src_configure() {
        # Some libs use $(AR) rather than libtool to build #444282
        tc-export AR
 
+       # Hack around struct mismatches between userland & kernel for some ABIs. #472388
+       use amd64 && [[ ${ABI} == "x32" ]] && append-flags -fpack-struct
+
        sed -i \
                -e "/nfnetlink=[01]/s:=[01]:=$(usex netlink 1 0):" \
                -e "/nfconntrack=[01]/s:=[01]:=$(usex conntrack 1 0):" \