net-dns/avahi: fix deprecated prune_libtool_files, bug #699752
authorAnthony G. Basile <blueness@gentoo.org>
Sun, 10 Nov 2019 18:28:50 +0000 (13:28 -0500)
committerAnthony G. Basile <blueness@gentoo.org>
Sun, 10 Nov 2019 18:29:02 +0000 (13:29 -0500)
Closes: https://bugs.gentoo.org/699752
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
net-dns/avahi/avahi-0.7-r3.ebuild

index 14dcdf4ec1594da32670b5bcb289d81076aa3d85..e3b9200743302fed03cd14d3c2a644175101b160 100644 (file)
@@ -195,7 +195,7 @@ multilib_src_install() {
        fi
 
        # The build system creates an empty "/run" directory, so we clean it up here
-       rmdir "${ED}"/run
+       rmdir "${ED}"/run || die
 }
 
 multilib_src_install_all() {
@@ -209,7 +209,7 @@ multilib_src_install_all() {
 
        dodoc docs/{AUTHORS,NEWS,README,TODO}
 
-       prune_libtool_files --all
+       find "${ED}" -name '*.la' -type f -delete || die
 }
 
 pkg_postinst() {